Solved

HDD not detected

Building new system, using old HDD. Bios doesnt detect HDD. Not sure what to do. It is getting power and spinning. System detected it earlier.

Asrock 870 extreme3
AMD 955
Gskill ddr3 1600 4gb
HDD samsung sp2504c
6 answers Last reply Best Answer
More about detected
  1. Is the SATA data cable secure at both ends?
  2. Yes, the data cable is secure. Even tried a different sata cable. Asrock customer service said to flash bios. Trying to figure out how to do that one. Have put the bios update on an external hdd, bios recognizes external hdd but cant find the update. Think i am gonna sleep on it. Thanks for any suggestions.
  3. Best answer
    Did you follow the instructions as specified by ASRock?

    http://www.asrock.com/support/BIOSUI.asp?cat=BIOS

    You said that you put the BIOS update on an external HDD. ASRock says that the hard disk must be in FAT32 format. If your external HDD wasn't formatted as FAT32 that's probably why it can't find the update.
  4. Had to buy a flash drive to update the bios. Wouldn't flash from my ntsf drive. Bios update went fine. Still not seeing my HDD. Starting to think it is the drive.
  5. Lucky enough to have a great local computer shop. Took my old HDD in, they determined it was dead. Sold me a new HDD at not too bad of a price. They plugged it in and made sure bios was detecting the new drive, and sent me on my way. Installing Windows now. Thanks for helping me ko888.
  6. Best answer selected by 30yearslater.
Ask a new question

Read More

Chipsets BIOS Hard Drives Power Motherboards Product