Sign in with
Sign up | Sign in
Your question

Windows 7 won't install to my SATA harddrive... ?

Last response: in Systems
Share
January 29, 2010 8:28:40 PM

Windows 7 can't locate my hard drive to install. My hard drive is recognized in the bios so I am pretty confused. It is asking for drivers. My hard drive is Samsung HD502HJ.


any help greaty appreciated.

This is my first build.
a b B Homebuilt system
January 29, 2010 9:27:27 PM

Install the SATA drivers first, then install the OS
m
0
l
January 29, 2010 9:51:27 PM

T_T said:
Install the SATA drivers first, then install the OS



No cds came with the drive, Also I can not find any drivers on Samsung's website.

m
0
l
Related resources
a b B Homebuilt system
January 29, 2010 10:33:51 PM

This issue you're having is probably because of a feature inherent to your motherboard. You see years ago, when SATA technology was just begining, Windows XP and older required the SATA drivers to be installed prior to the OS installation. Mobo manufacturers recognized this as a problem and so they embedded on to their boards, an emulator that would sort of trick Windows into thinking that the SATA hard drive was actually an IDE drive, thus allowing the OS setup to progress smoothly. My guess is that your motherboard is telling Windows that your SATA is IDE, but Windows 7 is looking for SATA and you told Windows to use SATA mode instead of IDE mode without first setting true SATA mode on your mobo.

Get into your BIOS. Make sure that your board is showing the HDD as SATA and not IDE. Reboot and try the install again.
m
0
l
January 29, 2010 11:26:33 PM

T_T said:
This issue you're having is probably because of a feature inherent to your motherboard. You see years ago, when SATA technology was just begining, Windows XP and older required the SATA drivers to be installed prior to the OS installation. Mobo manufacturers recognized this as a problem and so they embedded on to their boards, an emulator that would sort of trick Windows into thinking that the SATA hard drive was actually an IDE drive, thus allowing the OS setup to progress smoothly. My guess is that your motherboard is telling Windows that your SATA is IDE, but Windows 7 is looking for SATA and you told Windows to use SATA mode instead of IDE mode without first setting true SATA mode on your mobo.

Get into your BIOS. Make sure that your board is showing the HDD as SATA and not IDE. Reboot and try the install again.


I changed it to ACHI mode and it wouldn't boot at all, then back to ide and disabled the sata controller and it wouldn't read the disk. Not really sure what to do now/if I was doing the right thing to begin with >.<.

Thanks for trying to help.
m
0
l
January 30, 2010 2:17:43 AM

I really would like to get this fixed, so if anybody else has any input?
m
0
l
January 30, 2010 4:24:52 PM

Bump, my issue is still unresolved... and very annoying:/
m
0
l
January 30, 2010 9:45:45 PM

Sorry for quad posting but I solved my problem and am posting the solution just in case someone else has a similar occurrence


I used G Parted to format my Drive before installation into a NTFS partition.


G Parted is a free open source partitioner that can be booted as an img
Thanks for all the help=)
m
0
l
!