Sign in with
Sign up | Sign in
Your question

Trouble with Motherboard and possibly other hardware

Last response: in Motherboards
Share
September 2, 2010 11:13:00 AM

Hello Forum.

Long story short: Couple of months ago my PSU burnt out and fried everything except for the GC and the CPU. Having gotten all new components, my computer is still experiencing problems.

It won't start properly. I have tried everything, from exchanging components, testing individual hardware in another PC, sent the motherboard back to the manifacturer who couldn't find the flaw. I've double/Tripple checked the compatability and everything should be green across the board, and yet it won't work.

The problem is a tricky one so I'll try to explain it as clearly as I can.

When any PCI or PCI-E hardware is inserted into the motherboard, the computer won't load the harddisk and the computer is stuck in infinite boot. The fans are all working and I can hear that the harddisk starts up, but then it just keeps going in that state. No signal to the screen, the USB ports doesn't function (There's LED in my keyboard/mouse that lights up when the computer starts, but)

Without any PCI and PCI-E hardware plugged in, the computer starts up fine. The USB ports work (Keyboard/Mouse loads) and the harddisk loads just fine (I assume this due to the fact that I can turn the power off almost instantly, as opposed to the 10 second shut-down time I have to hold the power button for, when the PCI hardware is in)

I've plugged the harddisk into another PC and installed XP to make sure it had a working OS.

The harddisk is also completely new since my old one got fried with the other hardware. In addition I've bought another GC, so I've tried the 2 working ones I have, plus borrowed another pair from friends to see if it could be a problem with the two I own.

Current setup:

Motherboard: ASRock K10N78D NVIDIA nForce 720D Chipset (New)
GFX: ASUS HD5750 EAH5750FORMULA 1GB DDR5 (New)
CPU: Athlon 64 X2 6000+ AM2 (Old)
RAM: Kingston HyperX Dual Channel 4 x 1GB KHX6400D2K2/2G PC2-6400 CL5 (Old)
PSU: POWER LC6600GP2 V2.3 600W (New)
HDD: HITACHI 1TB 0F10383 7200RP/M (New)
Mouse/Keyboard: Razer Lachesis Cord Mouse / G15 Logitech (Old)

Everything is confirmed working properly in another PC except for the Motherboard, which the retailer has confirmed working and tested with the following hardware:

Athlon 64 3500+
GeForce 8600GT 512Mb
1024Mb Corsair XMS2 ram


The only difference I can find between our equipment is that they are using another socket CPU, but the motherboard should support both. Also after the motherboard came back I noticed that the locking mechanism for the PCI-E stick was missing. While not important, it made me wonder wether or not they just gave me a new one or tested the original one.

I'm at a loss here folks. The company I bought the Motherboard from has been seized by the Government for tax fraud and their entire inventory has been locked down - 2 days ago, so getting the money back at this moment in time is impossible, neither can I ask them to look at the board once again.

So my question to you is: Did I miss something?

Best Regards, Martin.
a c 302 V Motherboard
September 2, 2010 1:55:58 PM

Hi Daeica and welcome to the Tom's hardware forum.

Do u have the last BIOS version of the mobo?
September 2, 2010 2:11:20 PM

saint19 said:
Hi Daeica and welcome to the Tom's hardware forum.

Do u have the last BIOS version of the mobo?


Thank you.

I assume so, although assuming only gets one so far. I have installed the shipped CD that came with the motherboard, and from what I can tell the newest BIOS updates from ASRocks website are of a later date than the purchase, though that is of course never a safe bet. I have reset the BIOS during the testing but the results were the same, after the installation. I will try to install the BIOS updates on the harddisk via. another computer to see if it helps any.
Related resources
a c 302 V Motherboard
September 2, 2010 3:14:48 PM

The BIOS file isn't installed in the HD is installed in the memory of the mobo so ur idea can't works.

A better idea is borrow ur friend's CPU and install the BIOS with that CPU. Refer to the manual of ur mobo to know how do u do that in the proper way.
September 20, 2010 3:15:30 PM

Hello again. Sorry for the delay, but it took some time to get a new CPU.

The bad news: The problem still remains. Even with the new CPU, it still won't start up properly. The new CPU is a AMD Phenom II X2 555 black edition, brand new as of an hour ago.

Tried installing the BIOS with the old and new CPU after a hefty read-through of the manual, so no sollution there sadly.

- Martin.
!