Sign in with
Sign up | Sign in
Your question
Solved

Windows PowerShell

Last response: in Windows 7
Share
a b $ Windows 7
December 21, 2009 7:24:34 AM

In exploring my Windows 7 Ultimate, I found Start > Administrative Tools > Windows PowerShell Modules.
Upon activating the link, the following appeared in a window:

Windows PowerShell
Copyright (C) 2009 Microsoft Corporation. All rights reserved.

WARNING: File C:\Windows\system32\WindowsPowerShell\v1.0\Modules\PSDiagnostics\PSDiagnostics.psm1 cannot be loaded
because the execution of scripts is disabled on this system. Please see "get-help about_signing" for more details.
PS C:\Users\Gandalf>

In searching for "get-help about_signing" I found this on the net...
http://www.proudlyserving.com/about_signing.htm
but the language is a little out of my league.

Can someone please tell me in simple English how to resolve the above WARNING.
ie. how to enable "execution of scripts".

Thanks


More about : windows powershell

Best solution

a b $ Windows 7
December 21, 2009 8:44:44 AM

That link is fairly old, and doesn't seem to work nowadays. Have a look here instead.

The short answer is to type

Set-ExecutionPolicy Unrestricted

inot a PowerShell prompt (but you may want to look at the other security levels).
Share
December 21, 2009 1:27:54 PM

This error is most likely related to Internet Explorer 8 blocking script extensions or a setting within Windows Defender or a third party firewall.

All the message is really saying is, I can't run this script because it is now allowed.

Google how to enable execution of scripts in Windows 7
m
0
l
Related resources
a b $ Windows 7
December 21, 2009 1:54:38 PM

I think the OP is talking about PowerShell, not Internet Explorer. I've tested the method that I linked to and it works just fine.
m
0
l
a b $ Windows 7
December 21, 2009 4:23:55 PM

Thanks, ijack. You hit the nail on the head.
Your typo had me confused until I realized it was "into".
"inot" just didn't make any sense. :) 

m
0
l
a b $ Windows 7
December 21, 2009 5:15:51 PM

Sorry about the typo. The fingers work faster than the brain.
m
0
l
June 18, 2012 3:51:03 AM

Ijack said:
That link is fairly old, and doesn't seem to work nowadays. Have a look here instead.

The short answer is to type

Set-ExecutionPolicy Unrestricted

inot a PowerShell prompt (but you may want to look at the other security levels).



Thanks, issue solved!
m
0
l
July 31, 2012 2:08:35 PM

Ijack said:
That link is fairly old, and doesn't seem to work nowadays. Have a look here instead.

The short answer is to type

Set-ExecutionPolicy Unrestricted

inot a PowerShell prompt (but you may want to look at the other security levels).



This is the solution to the question. Thanks.

I always read up on any changes in Policy, like Google ExecutionPolicy. To feel conformable and understand what you just changed.

Although I have a recent CS degree, these operating systems have complicated and intertwined.

m
0
l
!