Sign in with
Sign up | Sign in
Your question

Data error cyclic redundancy check

Last response: in Storage
Share
January 31, 2012 1:51:52 PM

Hi,

I have a 1.5TB Western Digital external hard drive. I've had it since Christmas 2011. Last week, I tried to copy my iTunes media folder from an old XP-driven desktop that I started up for the first time in about 5 years. That folder contained 10.3 GB of music and took part of a day and all night to completely transfer to my external HD.

I then tried to transfer the iTunes folder from my external HD to my XP-driven laptop. Unfortunately, it failed due to "Data Error: Cyclic Redundancy Check". I removed the problem file and tried again. I received the same error, only this time it was for a different file.

I deleted the iTunes folder from my external HD and ran CHKDSK /f on the external hard drive.

I then tried to re-copy the iTunes folder from my desktop to my external hard drive. That process failed, again due to "Cyclic Redundancy Check" error.

I then downloaded the latest and greatest iTunes version to my desktop. I had iTunes copy all of the files into the iTunes folder. I ran CHKDSK /f and CHKDSK /r on my desktop drive. I then transferred the iTunes file to my external HD [it took several hours but it transferred].

After that, I again tried to transfer from the external HD to my laptop and it failed due to "Cyclic redundancy check" error. I have run CHKDSK /f and CHKDSK /r on the external hard drive several times.

I even downloaded Western Digital's diagnostic tool and ran both the QUICK and the EXTENDED tests. Both tests failed due to "Too many bad sectors on the drive".

The drive is recognized by both of my computers. There are no crunching or grinding sounds coming from my external HD. I also tried to download from the Internet to my external HD. That process had to be re-started several times due to "Cyclic redundancy check" and "Delayed Write Fail" errors. The file, however, is accessible and appears to be fully functional, as are all the rest of the files on the external drive.

I am currently at a loss for how to proceed. I have a new drive coming from WD. However, my concern is how do I get the data off my external drive without corrupting my new external HD, my laptop HD, or my desktop HD? Is there anything I can do to troubleshoot the troubled external HD? And why did this issue happen all of a sudden? Previously, I had transferred my laptop HD to the external HD and several downloaded files from the Internet to it without any troubles.
a b G Storage
January 31, 2012 2:12:07 PM

Have you tried using Robocopy instead?

http://ss64.com/nt/robocopy.html

It has much better transferring abilities than windows built in file transferring system.

It should not corrupt any of your drives while copying the files with robo copy.

If that doesn't work - it's possible your drive could be dieing (especially if it's 5 years old now).

One last thing - if none of those work - you might have to re-download all the music, and you may have to contact apple to re-download them all, it may be a pain and a long process, but at least you should be able to get your songs back.
m
0
l
January 31, 2012 4:07:23 PM

I have not tried Robocopy. I was simply using the standard Windows drag and drop transfer method. I am in the process of downloading Robocopy for XP from Microsoft on my laptop. I'll have to do the same on my desktop, too. First, I'll see if I can't pull the music off the external HD to my laptop with Robocopy.

I'm pretty sure the external HD is dying or has an issue with it. Both diagnostic tests failed on the drive and WD blessed it off as a failed drive.

My desktop is all of 8 years old now. My laptop is going on 6 years old now.
m
0
l
Related resources
January 31, 2012 7:05:40 PM

Chainzsaw:

Thanks for the info on ROBOCOPY. I had never heard of that before. I was able to find everything I needed, including a graphic user interface of the command here: http://www.techrepublic.com/article/get-a-gui-for-roboc...

With the GUI, ROBOCOPY continues to run well behind the scenes even though it instantly produces a message window saying that it has completed the copy. I realized this when I went to the transferred folder and saw that it only had 800MB of stuff and not the full 10.2GB. When I went to delete it [thinking the process had failed] Windows would not let me because it said the folder was in use. I checked properties again, and the size of the folder had grown. ROBOCOPY was doing its thing.

Thanks for the tip. I was frustrated beyond belief. I owe you one. I plan on using ROBOCOPY to transfer all my data from my current external HD to the new one as soon as it arrives.

Everything seems to be working just fine :-)
m
0
l
a b G Storage
February 1, 2012 3:00:07 AM

Glad it worked out for you! You might want to back up your data just in case (even dual layer DVD's can hold about 8GB of data, and are quite cheap to acquire).

Take care.
m
0
l
February 7, 2012 11:25:48 PM

I got my new external hard drive the other day. I am currently trying to get my data off of it and onto the new one. This task has proven to be quite difficult. I tried to use robocopy to mirror the drive but unless I am missing something in the command "robocopy E:\ F:\ /mir " it does not work.

Unfortunately, it looks like I will not be able to save some of my files.
m
0
l
!