Sign in with
Sign up | Sign in
Your question

RAID 5 failed; can it be rebuilt?

Last response: in Storage
Share
February 1, 2012 1:41:25 PM

I recently did some major upgrades to my system (CPU cooler, Power supply, Video Card, and Memory) and for a while I couldn't get the motherboard to boot. I finally figured out that the cause of the non-boot issue was that the new power supply didn't like using the SATA rails from the old one (both modular systems) so after swapping out all the internal power cables, all was good to go. However, as I was troublshooting the non-booting of the mobo, one of the steps from ASUS was to reset the CMOS.

When I finally got the system to boot, I discovered that resetting the CMOS wiped the information out of the Intel Storage Manager's onboard RAID setup using the ICH10R chip. I had a three-disk RAID-5, and the manager is now showing it as "failed" with 1 member disk present, and the other disks showing as "non-member disks" (all disks are recognized, though). Is there any way that I can get those other disks to be recognized again on that RAID? I've got hundreds of hours of video projects for work on that array, and I can't afford to lose them. I hadn't expected any of my upgrades to be affecting my drives, so I didn't bother with backing that array up. Lesson learned, I guess.

I'm also having another issue where my mobo isn't recognizing all 24 GB of ram I just gave it (it's the Asus P6T6 WS Revolution with an i7-920 running 7 Ultimate), which it should do. I've been advised on another forum to update my BIOS, since it's a 2009 version, and by updating it I should see the full 24GB. However, I'm concerned that by updating the BIOS, since it will also update the Intel RAID controller, I'll lose any hope of ever getting that RAID rebuilt.

So my questions are these:

1. Is it possible to get the controller to recognize at least one of the other disks in the RAID to rebuild it?

2. Do I need to wait to address the out-of-date BIOS issue until I've gotten the RAID problem figured out?

Thanks!

More about : raid failed rebuilt

February 1, 2012 4:59:38 PM

Ok; never could get the system to remount the drives properly, but I purchased the RAID Recovery for Windows from Runtime Software and it was able to resurrect the information off the drives and it's copying it to a new location so that I can go in and rebuild the array.
m
0
l
a b G Storage
February 1, 2012 5:37:23 PM

I had this issue once did you go back into controller mode and set it back to raid cmose reset defaults drive controller back to dma some say IDE (not sure why on sata) Freaked me out but seting it back to raid fixed me right up.

Thent
m
0
l
Related resources
February 1, 2012 5:43:07 PM

Yeah, I tried that Thent... It had rest to IDE, but resetting to RAID still left me with only one member disk present. Thanks for the suggestion, though!
m
0
l
February 15, 2012 4:20:52 PM

I had this issue with Windows 7 RAID 5 and Intel ICH9R. I set the 3 RAID disks back to normal disks, rebooted, re-added them to a new RAID 5 array (Warning All Data Will Be Lost - Not True!) After re-adding them to a new RAID 5 array, I ran the Windows 7 disk in Repair mode, and the Original RAID 5 array booted right up with ALL of my data intact.
m
0
l
April 18, 2012 5:41:16 AM

I have a motherboard that does not auto rebuild so if a drive fails I have to ghost the disk and delete everything and recreate the raid disk then ghost back my disk onto the newly created raid disk. Test before you need it thats what I did! Hope this helps.
m
0
l
!