ATI 5670

Hello. Installed Sapphire ATI 5670 video card. When used on game black lines appear from a central point. Can still play game. Videos played from that point on dashed interference type lines. Suggestions? thanks
10 answers Last reply
More about 5670
  1. Hello and welcome to the forums :)
    Do a clean reinstall if your VGA driver,here is how:
    1_Download and install "Driver Sweeper" from here:
    http://www.guru3d.com/category/driversweeper/
    2_Remove the current driver from add/remove programs and restart and boot to safe mode.
    In safe mode and open Driver Sweeper,choose ATI and click remove.
    3_Restart and boot normally to windows and install the driver again,after the installation restart the PC and see if it works then or not
  2. Thanks for that. Will give it a try.
  3. No problem,report back about how it goes
  4. Maziar said:
    No problem,report back about how it goes


    Didn't work same problem. Could it be the power supply? (350w). Only occurs under load then need to rebootbut.
  5. http://www.amd.com/us/products/desktop/graphics/ati-radeon-hd-5000/ati-radeon-hd-5670-overview/Pages/ati-radeon-hd-5670-system-requirements.aspx
    "400 Watt or greater power supply recommended (500 Watt for ATI CrossFireX™ technology in dual mode)"
    So it maybe your PSU.
  6. Thanks for that. I'll get a new psu (500w). Appreciated. Let you know how it goes.
  7. No problem,yes tell us how it goes :)
  8. 500 psu installed same problem.
  9. Can you test your card in another specs ?
  10. Reduced GPU clock to 700 and it seems to work! A developing problem?
Ask a new question

Read More

Radeon Graphics Cards Games Sapphire ATI Graphics