Closed

Wireless connection OK if unsecured, no connection if secured...

Hello,
I just got a new laptop (asus K52F-SX051V) with windows 7 OS.
When trying to connect to the router, it works as long as the router is not secured with a WEP or WPA key (which makes me think the router is compatible with Windows7?)
As soon as I secure the router, the laptop can see the network but will not connect to it, even though I know the correct passwords (installed them myself).
Does anyone have any ideas?
Windows 7 is new to me, maybe I need to change a setting, but I wouldn't know which one...
Thanks for helping ! :wahoo:

PS; the same problem occurs both at home and at the office. Two different routers.
2 answers Last reply
More about wireless connection unsecured connection secured
  1. Well, It did work fine with XP or Vista... Correct? So, I would suggest that you probably should check Windows 7 compatability of the item. Because, The OS is so new... Not EVERYTHING is compatable with it. If there is a direct annotation on the box or the WIFI router itself, then we we have to probably preform a hard reset. I belive that (Its different on every router) to do this you have to find the reset button somewhere probably on the bottom....Press it, then, you need to reset the passwords and everything. You could also have a firewall problem. Let me know.
  2. compuwizkid said:
    Well, It did work fine with XP or Vista... Correct? So, I would suggest that you probably should check Windows 7 compatability of the item. Because, The OS is so new... Not EVERYTHING is compatable with it. If there is a direct annotation on the box or the WIFI router itself, then we we have to probably preform a hard reset. I belive that (Its different on every router) to do this you have to find the reset button somewhere probably on the bottom....Press it, then, you need to reset the passwords and everything. You could also have a firewall problem. Let me know.


    Thanx, I'll let you know.
    Internet worked (and still works) fine on my old (and slowly dying) laptop with XP. Never used Vista, so I wouldn't know...
    As far as compatibility goes, I find it strange that I CAN connect when I disable the security key.
    My laptop just won't connect when I re-install and enter the password.
    If the problem persists, I'll try the resetting thing on the router.
    Thanx for replying so soon :)
Ask a new question

Read More

Configuration Routers Connection Windows 7 Wireless Networking