Sign in with
Sign up | Sign in
Your question

Screen Resolution issue

Last response: in Graphics & Displays
Share
January 26, 2010 4:05:53 PM

Hello,
I'm on Windows XP. I've the Samsung SyncMaster 2233SWPlus monitor & it's latest driver. I recently downloaded the latest nVIDIA video driver - v196.21. After I installed it, it automatically changed my resolution from 1600*900 to 1920*1080. Now, when I change it back to 1600*900, this is what happens:



If I change it from 'Normal' to 'Wide' from the monitor's settings, this is what happens:



Also, when the resolution is 1600*900, the monitor's information says it to be 1280*960, but it shows it to be 1920*1080 when the resolution is 1920*1080 (which also happens to be the native resolution).

This was not an issue with the previous nVIDIA driver.

Kindly, help!

P. S. - I came across this piece of information while trying to find out possible solutions in Google.

Quote:
Flat screen / LCD / TFT / Plasma / laptop displays aren't as flexible as they are designed with a "native resolution" in mind. For example many 17 inch TFT displays run happiest at 1280 x 1024. If the computer is set to less, they will still run at 1280 x 1024 but instead of displaying one monitor pixel for one computer pixel (1:1) they will show two or three monitor pixels for one computer pixel. This results in less sharpness and tends to look really ugly. Alternatively they may display the smaller screen size one pixel for one pixel but in the centre of the screen with a black or white border around.


So, what I guess is happening is the latter case with a black border around. So, how do I get my LCD monitor to do the former i.e. display two or three monitor pixels for one pixel? I'm sure it can be done as it was automatically doing so before.
January 26, 2010 6:27:12 PM

you should be able to turn on scaling in the Nvidia control panel but frankly, the way you are getting those conflicting resolutions is a concern. If you have the correct monitor driver installed it should not have set the display to a resolution it was not listed as supporting. Short of messing around with the different scaling options and possibly uninstalling and reinstalling the monitor driver package, I would seriously consider going back a version in the Nvidia driver.....is there a reason you upgraded the drivers?

m
0
l
January 26, 2010 7:45:35 PM

Yes, I did it because the latest patch of the game Batman: Arkham Asylum kept nagging me to do so...

P. S. - I'll try installing older versions of the driver & update accordingly.
m
0
l
Related resources
January 26, 2010 8:07:17 PM

1920x1080 is your monitor's native resolution, why not just run it there?
It will defiantly look better than when you interlope it....

Try going to the Display section in nVidia's control panel.
In the Adjust Desktop Size and Position section make sure it is set to 'Use my display's built-in scaling' or 'Use Nvidia Scaling'.
Try both, one of them should work for you.
m
0
l
January 26, 2010 9:11:26 PM

Reverting back to older drivers wasn't of much help.

Frankly, it hurts my eyes to see everything so small. Besides, even in 1920*1080 resolution, there are black borders albeit smaller in size (about 0.5 inches on both sides). Also, I couldn't find any such options under 'Adjust desktop size and position' because my connection is Analog & not Digital. All I can do is adjust the screen position to the left, right, top and/or bottom by which it moves the Windows only & not the screen. I guess what I'm looking for is an option to change the height & width of the screen.

P. S. - I forgot to mention this before, but even my system start-up screen has become smaller in 'Auto' & stretched out (which is what it used to be before) in 'Wide'. It used to be stretched out in 'Auto'.
m
0
l
January 26, 2010 11:36:14 PM

well like outlw said and I will second, the native resolution of the panel is the ideal resolution.

If the native res is 1920X1080, set it to that, confirming the refresh rate matches.....if things are too small, you can adjust other settings such as font and icon size so that things are not so tiny...

also, it sounds like you are using an analog connection...are you connected to the monitor via DVI or VGA?
m
0
l
January 26, 2010 11:50:21 PM

just out of curiosity I was looking over the manual for your monitor and according to it, 1600X900 is not a listed resolution.

I am no genius so maybe I am wrong, but in general, it is not a good idea to run your monitor at resolution it is not listed as supporting.

Stick to resolutions and refresh rates listed in your manual and you should have better luck.....once again though, 1920X1080 with a 60Hz refresh rate is the optimal setting for your monitor.
m
0
l
January 27, 2010 12:53:34 AM

Yes, I'm connected via VGA (Analog).

The list which you are referring to isn't a list of the formats which are only supported by the monitor. It's a list of the 'Preset Timing Modes' which means if the signal transferred from the computer is the same as the Preset Timing Modes, the screen will be adjusted automatically. However, if the signal differs, the screen may go blank while the power LED is on & will come back on once the screen has adjusted to the new resolution. If a particular resolution wasn't supported by the monitor, then it wouldn't have come up in the first place in the list of available resolutions under Windows Display Properties. Also, when switched to a non-supported resolution, the screen would go blank & wouldn't come back on. It asks for a confirmation for the change which is displayed for 15 seconds from the time of adjustment. If no input is received from the user, then it'd automatically come back on at the previous resolution it was at before trying to adjust to the new resolution after 15 seconds.

Besides, not even one of resolutions listed supports the 16:9 wide aspect ratio except the 1920*1080 resolution. Even the 1920*1080 resolution has 0.5 inch black borders on both sides. Is there a way to stretch it out?
m
0
l
January 27, 2010 1:08:42 AM

You manual specifically states that modes not listed in the table are not supported but at any rate, it's irrelevant.

Don't you have a control panel interface for the Nvidia driver? That is what I would to modify display settings, not the Windows Display Properties interface...that is also where you should find your scaling options as well.
m
0
l
January 27, 2010 3:16:13 AM

There are no scaling options under 'Adjust desktop size and position'. I think the scaling options come only after connecting via DVI (Digital). Come to think of it, will it be a good idea to get a DVI connector to solve the problem?

P. S. - I hooked up the monitor to an old machine running on GeForce FX 5200 & Windows XP & it adjusted perfectly. So, I'm guessing the issue is video card and/or it's driver related & not monitor related...
m
0
l
January 27, 2010 11:05:24 AM

DVI vs. VGA? Well that is a source of much argument......

http://www.tomshardware.com/forum/52864-3-tomshardware

I would tend to opt for the DVI option but I don't game a whole lot (well, except for MAME and thats not really high load or anything), as you should see crisper lines via DVI....though your setup may actually display a better picture via analog, you won't really know unless you try.
m
0
l
January 27, 2010 11:11:37 AM

also, what is the name and version of the Nvidia control panel s/w you are using? Is it the Forceware 90 or?
m
0
l
January 27, 2010 12:11:04 PM

It's nVIDIA Control Panel. Version keeps changing when I keep upgrading or downgrading the driver...
m
0
l
January 28, 2010 3:32:51 PM



As you can see, there are no scaling options as it's on Analog display & not Digital display. Heck, it even detects it as a CRT monitor & not a LCD monitor.

P. S. - I followed it up in nVIDIA forums: Screen Resolution issue.
m
0
l
January 28, 2010 4:07:29 PM

DId you try using this workaround that was listed in the link amdchuck listed :

Quote:
You can get around this problem by setting your own custom timings:

In the control panel select Advanced View then Manage Custom Timings

Create new - enter the native resolution, refresh rate, colour depth and select the Timing standard as Auto or DMT.

For some reason it took a couple of times selecting this new timing for my monitor to actually change, but all is working fine now without any scaling.
m
0
l
January 28, 2010 4:48:42 PM

Yes, didn't work...

P. S. - I talked with Samsung Technical support, they only went so far as to reset my monitor settings to default factory values & suggested it to be a issue with the video card and/or it's driver. I talked with a Live Assistance support from nVIDIA, he only pointed me to the latest beta version driver - 196.34. I doubt it'll fix anything. Oh well, fingers crossed!
m
0
l
January 28, 2010 5:57:03 PM

it detects it as a CRT? this is just odd.....

I would be tempted to obtain a DVI cable as it might just be the easiest way to resolve the issue since it will force the Digital/LCD mode....sure it won't explain why it's all jacked up using the VGA port but hey, it will probably resolve the issue.
m
0
l
January 28, 2010 6:15:43 PM

Well, the thing is I got an external TV tuner card which passes only analog signals connected to my monitor. So, I'm hoping for another workaround solution to it. However, if everything else comes to fail, I guess I've got no other option. Besides, the problem didn't exist before, so how come it crops up when the driver is updated? :pfff: 

P. S. - The latest beta driver 196.34 didn't work either...
m
0
l
January 28, 2010 6:23:16 PM

IF using a DVI cable solves the issue, why not use both the DVI and VGA connections?
Set it up like you have two monitors in Clone mode and switch between the inputs using the display.
Defiantly not an ideal fix but if it gets everything working when not using the TV card....
m
0
l
January 28, 2010 6:56:22 PM

outlw6669 said:
IF using a DVI cable solves the issue, why not use both the DVI and VGA connections?
Set it up like you have two monitors in Clone mode and switch between the inputs using the display.
Yes, I was thinking of doing the same as well. However, I'm going to wait for an official response from nVIDIA...
m
0
l
January 28, 2010 7:05:31 PM

Like I said, defiantly not an ideal fix but if it works....
I still think you should run it at your native resolution though.

It will give you the best quality and you can always increase the native font and icon size.


[:tapko:3]
[:thegreatgrapeape:3]
m
0
l
January 28, 2010 7:07:50 PM

Is it the sort of external card that uses a Y adapter VGA cable and connects between your graphics card output and monitor input?

If yes, it might be worth removing it from the loop just to eliminate it as a potential cause.....I don't really have any reason to suspect it as a cause but if it is that style of tuner, it is a link in the graphics chain and therefore, could conceivably be the problem...

As far as why it happened when you updated the driver...I don't know, you would think that would indicate the driver is to blame and removing the driver would remove the problem but obviously that is not the case....some sort of file corruption I imagine....

I imagine you didn't create a System Restore Point prior to the driver upgrade?
m
0
l
January 28, 2010 7:30:06 PM

amdchuck said:
Is it the sort of external card that uses a Y adapter VGA cable and connects between your graphics card output and monitor input?

If yes, it might be worth removing it from the loop just to eliminate it as a potential cause.....I don't really have any reason to suspect it as a cause but if it is that style of tuner, it is a link in the graphics chain and therefore, could conceivably be the problem...
Yes. Also, I did it even before approaching here. Needless to say, it didn't help...

amdchuck said:
As far as why it happened when you updated the driver...I don't know, you would think that would indicate the driver is to blame and removing the driver would remove the problem but obviously that is not the case....some sort of file corruption I imagine....

I imagine you didn't create a System Restore Point prior to the driver upgrade?
The question wasn't directed at you, but rather at nVIDIA. Also, as luck would have it, no...

P. S. - After a grueling 3 hour chat session with a Live Assistance Support from nVIDIA, the current status of my query is at 'Level 2', whatever that means...
m
0
l
January 28, 2010 8:36:38 PM

brutal......well they are assuredly better equipped to help than I am. Good luck
m
0
l
January 28, 2010 10:21:37 PM

Thanks for all of your help. I really appreciate it. I'll update my status if any significant changes occur...
m
0
l
February 2, 2010 12:31:33 PM

I purchased a DVI-I cable which fixed the black borders issue. However, I also have an external TV tuner card via which I watch TV & it sends out Analog signals only. The analog cable is still hooked on to my monitor. How do I go about configuring to switch back & forth between Windows & my TV?
m
0
l
February 12, 2013 9:35:21 PM

what are your dpi setting?
i think that`s what you ment here are two examples in pixel manipulation:
100% of normal size = 96 pixel per inch(default)
200% of normal size =196 pixel per inch
normal is xp dpi scaling 120 pixel per inch(125% dpi)
m
0
l
!