Sign in with
Sign up | Sign in
Your question

Option ROM, BIOS, and Booting (Oh My!)

Last response: in Motherboards
Share
September 6, 2010 1:09:04 PM

So I put together this workstation; SuperMicro X8DA3, 24GB RAM, Dual E5520, etc. for my photography and some gameplay. And since day one, I have been unable to use the two RAID systems on the board at the same time. When either the Adaptec or Intel is turned on in the BIOS, the LSI disappears with the note, 'not enough space option rom.' Several months of emails back and forth to SuperMicro and a couple of BIOS's later and voila: same thing. At this point I figure I'll live with it but then a drive went south last week. I says to myself, "hmmm, you know, two RAID arrays would sure be handy. And I already paid for it!" I go back on line and while I cannot find other folks with the same board having the same problem, I can find other folks who have had similar experiences. Slowly I start to get what is going on. There is not enough option ROM memory for the video card, and both RAID systems at the same time. I tested this by installing an older PCI video card in the box and shazam! I get the Adaptec and LSI to play together. (Intel still is not interested in coming to the party.) Unfortunately, I have no interest in using the older card while I have a perfectly fine HD5750.
So here are the questions. It appears that the video card is eating up at least half of the ROM during boot. While I would like to continue using this card, are there any other manufacturers that use less ROM? This is not a spec that is usually listed. (I've emailed Sapphire to see if they have a firmware which will help.) Are there any other ways to free up ROM? I've disabled as much in the BIOS as I can find, but that has not helped. What are some of the other devices that might be using ROM during the boot? Any and all information and insight is most welcome.

Bobby
September 6, 2010 2:41:17 PM

Could you tell us what you've got attached to those controllers, hdds that is. just out of curiosity.

also have u tried pluggin the video card into a different slot and see if it'll boot up?? i imagine it'd have a few slots seeing its a dual cpu board. that 5750 wont max out the highest bandwidth slot and "maybe" knowing what computers are like it might make a difference.
September 6, 2010 3:20:53 PM

Four SAS and four SATA on the LSI. I want to move the SATA's over to the other RAID so I'm not mixing, although I've had no problems. Yes, I've tried both slots as per SuperMicro's suggestion and that did not work. Remember, that this board works like a charm and starts everytime. I just cannot turn on the Intel or Adaptec RAID and have the LSI show up as well. All the other boards that have seen this problem are either workstations or servers. And all of them have the same inability to run two different types of RAID at the same time.
Related resources
September 7, 2010 12:18:10 AM

:(  disappointing for a high end board. I know you said u tried the 2 16xPCIe ports but what about the 8x, will it boot? I'm clutching at air here. and don't worry the 8x slot won't impact performance on the card if it works.
September 8, 2010 9:31:59 AM

Ain't got one. Only a 4x that won't take the board. The BIOS is also a limiting factor. I had hoped that when I got the old PCI card working, that I could leave that in as the 'boot' card. (Someone else used this trick on another brand of board.) The idea is to set up the BIOS to locate the PCI card that uses less ROM and use that for the boot screen. Once the operation system takes over, it locates and turns on the PCI-x card. Unfortunately, the BIOS does not have the ability to tell it to boot from PCI first. And when I installed both cards, it would use the PCI-x card for booting even though the PCI card was one slot above it.
September 26, 2010 7:44:38 PM

Fixed . . . sort of.

I purchased a Zotac Nvidia graphics card to test out. Cheap one; ten bucks after rebate and put it into my box. Low and behold, I can boot both the Adaptec RAID and LSI Megaraid at the same. But wait, there's more!
I then reinstalled the HD5750 card as well. The computer boots only the Zotac (in the first PCI-x slot) and again I can use the Adaptec and LSI at the same time. After some reboots and configuring Windows to turn off the Zotac I've got my RAIDs and everything is working fine. Sort of.
The problems?
Well, all my PCI-x slots are used and while I have no use for both right now, if I want to use one in the future, I'm SOL.

My Dell monitor can handle both inputs fine, but changing back and forth after the boot kinda sucks. Especially with the fancy touch sensitive buttons used by Dell. I guess I'm not sensitive enough.

I had to spend money. Yeah, only ten bucks, but still I had to spend money.

The Intel RAID still does not work.

What did I learn? That the old reliable BIOS has limitations and maybe we need to look at alternative methods. That the support from Supermicro was slow and that the support from Sapphire was very fast. But neither one had a clue as to what the problem was, or even how much memory each device uses. I still don't know who is responsible for that; the board engineers or the makers of the individual components. And this would be helpful information. One could know in advance what card will work best with the peripherals that they would like to use. I would like to know the answers to some of these questions, but perhaps it is just not meant to be.
!