Sign in with
Sign up | Sign in
Your question

Bad Bios Flash - Adapter Not Found

Last response: in Graphics & Displays
Share
January 26, 2010 11:50:02 PM

Wow... I feel like a screw up. I've been saving up FOREVER... and I finally scrapped enough money to build an $800 computer, $200 of it being for a Sapphire 5770 Vapor X. It was a great card, but I always had issues getting display. After 5-15 reboots later, it would finally display (regardless of the monitor, used my HDTV and my old 19"). It was incredibly unstable and I found out it has 720/800 shaders. Well the bios were what probably messed the card up a bit, because it was one of the few in the batch of cards with incorrect bios installed. So I went ahead and flashed it, like Sapphire told me to but not through them.

I picked up a copy of the Asus 5770 bios, supposedly they were better anyways and would work with my card. I popped up a bootable USB, got into DOS, and flashed like any other time. My card quit working after reboot...

Now I was screwed, I got the 5 beeps and no display. I picked up a PCI card to use temporarily because I thought I could reflash it with the Sapphire bios they told me to use :??:  .

I get back into DOS and atiflash now doesn't respond to the flash "Adapter not Found"
Ok... I type atiflash -i
"No Adapters Found"

Great. I was using a Geforce PCI as a primary until I can get the card working. I won't be able to afford another one for several months and I'm already excited to use my new system. I already emailed in the UPC code for a rebate like a dummy (they wanted it in 5 days or less!) so I can't access that for the RMA (the card is actually defective on top of this).

I heard borrowing a second card and then crossfiring would fix it... but I doubt it!

Is there ANY WAY to fix this. Please help. Greatly appreciated -Dereck
I know how to reflash it if only it stopped saying "Adapter Not Found" and recognized it.
a c 130 U Graphics card
January 27, 2010 7:30:05 AM

Im not exactly an expert at this so check it first but do you not need to use atiflash -p to make it write the new Bios ?
I thought i was for identifying the adapter
Or are you saying you tried the p comand and it came up bad so you then ran i to check the card ?

Mactronix
m
0
l
Related resources
January 27, 2010 11:07:58 AM

-f is to force the flash.
m
0
l
a b U Graphics card
January 27, 2010 11:18:34 AM

Can't you still return the card (through Sapphire)? Despite sending in the UPC, it is still under warranty and truly was defective. you can just tell them you tried to update the BIOS and something went wrong and you should be a ble to send it back for repair or (hopefully) replacement.
m
0
l
January 27, 2010 11:27:51 AM

Alright, well I'm going to try that. But I hear Sapphire is a pain with RMAs and the UPC code won't help me cause :(  they don't send it back right after rebate?
m
0
l
a b U Graphics card
January 27, 2010 4:12:47 PM

All of the pertinent info that was on the UPC on the box should also be on the card itself (a sticker). The only problem cutting off the UPC causes is that you can't send it back to the retailer (example: Newegg). Each does vary, though since initially this was their incredible screw up, I think they should be fairly lenient (flashing a GPU BIOS isn't a commonplace thing). So all you can do is email (or perhaps call) their service/RMA/Warranty people and see what they say.
m
0
l
February 17, 2010 10:16:34 AM

bro i have exact same prob with my sapphire 4670, and i was send it for replacement 2 days ago.
i need to know what u did than :o 
dose u replace or fix yourself? and dose they really void warranty after flashing bios? and how much time thy take for replacement? :heink:  :pt1cable:  :ouch: 
m
0
l
!