Sign in with
Sign up | Sign in
Your question
Solved

Advice needed: Uninstall a Jmicron controller

Last response: in Motherboards
Share
September 8, 2010 3:54:34 PM

I was having problems with an ESATA drive and accidently installed an incorrect JMicron PCI express to sata II host controller. I thought I was installing a controller for the normal hard drives. I don't have a PCIe SATA controller. Doh!
ESATA problem is sorted.

Now when I now boot the controller says it is looking for a drive and pauses for about 30 seconds which seems like an eternity when you're in a rush.
Any idea how to uninstall said controller?

I'm not too high tech so keep the advice simple please. :) 
Many thanks.
Andy

PC Spec:
Windows 7 Professional 64 bit
Asus CROSSHAIR IV FORMULA 890FX Motherboard - Bios 1005
AMD Phenom II X6 1055T 2.8GHz
Crucial 4GB (2x2GB) DDR3 1333MHz/PC3-10600
Sapphire HD 5830 1GB GDDR5 x 2 in CrossfireX - Catalyst 10.8
Corsair 650W TX Series PSU
OCZ 60GB Vertex 2E SSD 2.5" SATA-II Read 285MB/s Write 275MB/s
Samsung HD103SJ Spinpoint F3 1TB Hard Drive SATAII 7200rpm 32MB Cache
September 8, 2010 6:31:36 PM

Sorry, I asked that question really badly. My small brain was trying to do my day job and home PC problems at the same time!

Basically when I boot I have the following screen appear after the AMIBIOS screen:

JMicron Technology Corp.
PCI Express to SATA II Host controller ROM v1.07.16
Copyright (c) 2005-2009. JMicron Technology Corp.
Detecting Drives, Please Wait...


I don't have a PCIe to SATA II card. All my HD's are connected direct to the motheboard. I don't know if I accidently installed a driver for this. The JMicron screen appears to be there for possibly a minute. I'd like to remove this.

Thanks in advance,

Andy

Best solution

a b V Motherboard
September 8, 2010 7:16:18 PM
Share

The PCIe to SATA to card is built in the the motherboard. No drivers will do this as its in the BIOS. Look in the BIOS for some settings to disable that controller.
Related resources
September 8, 2010 7:47:44 PM

Thanks Snipergod87,
That's solved it. I'd flashed the bios in an attempt to solve my earlier the esata problems. When I was putting in bios the settings I had enabled the onboard SATA controller, now it's disabled I'm back to super fast boots :sol: 
I thought the enabling onboard controller would be neccessary to operate the hard drives. No idea what that does then! I tend to put settings in to bios and just hope I've done the right thing. Mayby I should read up!
a b V Motherboard
September 8, 2010 8:15:01 PM

Glad to hear that fixed it for you
September 8, 2010 8:18:44 PM

Am I being stupid here. I can't see a 'select best answer' / mark solved option? Can't see any stickys on this.
a b V Motherboard
September 8, 2010 8:24:41 PM

The button should be there under any of the posts where you mark it as best answer (around the reply box I think). Its been awhile for me so I dont remember.
September 8, 2010 8:52:51 PM

No, the button isn't there. :??: 
I'll check out in the site bugs forums and see if I can get it resolved. Hence to say, it's yours when I've got the button!
September 9, 2010 8:01:28 AM

Best answer selected by andy_s.
September 9, 2010 8:03:12 AM

Last night, I was unable to edit the message to change the thread from a discussion to a question which allows the orignal poster to select best answer. Tried again this morning and it worked!
!