Ethernet connection makes wireless unstable

Ok, I am very new to these forums and I got so fustrated that I am hoping someone can give me a solution to my problem. Here is the situation (sorry if i typed too much):

I have 3 computers, one being a desktop and the other two are laptops. My desktop is connected wired internet via ethernet cable to my router and my laptops are wireless. Whenever my desktop is on, the wireless connection on both laptops becomes unstable and disconnects every 2-3 minutes and then reconnecting again. They both disconnect at the same time. When my desktop is turned off, my wireless network is flawless and never drops connection. I thought the problem was the router, but it isnt because I tried three different ones and same thing occurs. The problem isn't my ISP and I even tried buying a wireless card for my desktop making it wireless but doing that has the same effect. After 2-3 months of messing around with almost everything you can think of, I am stumped. Something is wrong with my desktop, does anyone know the solution? Playstation 3 wireless does the same thing.

I am confused and fustrated to the point of exhaustion. Please help!
24 answers Last reply
More about ethernet connection makes wireless unstable
  1. try only having 1 wirless device connected at once and see if you get the problem then, see if you can pin down the 1 effecting PC/laptop.

    I take it your router is giving out the DHCP?

    Do all devices have a unique host name?
  2. Yeah, It has boiled down to just the desktop causing the problems. Yeah router is giving out DHCP and all have unique host names. Around 3 months ago this problem has never occured, it all of a sudden started happening.
  3. Have you scanned you desktop for Malware?
  4. If you Have Window7 , Search in the Help file for "How do I prevent my computer from switching between wireless access points?" , I think the problem is this.

    here I have copy important part of that HELP for you :
    Turn off automatic switching in one or both of the network profiles. Here's how to do it:

    Click to open Manage Wireless Networks.

    Right-click the network profile in which you want to turn off automatic switching, and then click Properties.

    Click the Connection tab, clear the Connect to a more preferred network if available check box, and then click OK.

    This turns off automatic switching.
  5. Both laptops have automatic switching off, and I've scanned the desktop with Symantec Endpoint Protection and the free AVG software. :( I am starting to think there is a virus on my desktop, but it found nothing.
  6. Try Malwarebytes Anti-Malware.
  7. I am going to try that tonight. Hopefully it finds something
  8. The anti-malware found nothing. Any other ideas guys?
  9. hopefully some computer genius can tell me what the heck is wrong.
  10. Tell us more about the behavior of the laptops while your desktop is plugged in.

    Run an extended ping (start>run>cmd>"ping -t" - assuming that's your gateway.
    Run another extended ping to google (ping -t)

    Do the above for both laptops and the desktop and provide the results.

    Are you getting packet loss to just the router or both? How often & how long each time? Desktop stays connected the entire time?

    Also worth it to check your router setting for QoS, NAT settings (is this capped?), port forwarding, etc...
  11. Microsoft Windows [Version 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.


    Pinging with 32 bytes of data:
    General failure.
    General failure.
    General failure.
    General failure.

    Ping statistics for
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),


    Pinging [] with 32 bytes of data:
    Reply from bytes=32 time=40ms TTL=52
    Reply from bytes=32 time=18ms TTL=52
    Reply from bytes=32 time=25ms TTL=52
    Reply from bytes=32 time=20ms TTL=52

    Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 18ms, Maximum = 40ms, Average = 25ms


    Pinging with 32 bytes of data:
    Reply from bytes=32 time=6ms TTL=128
    Reply from bytes=32 time=4ms TTL=128
    Reply from bytes=32 time=3ms TTL=128
    Reply from bytes=32 time=4ms TTL=128

    Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 3ms, Maximum = 6ms, Average = 4ms

    The first ping is when it was disconnected. The desktop and other laptop had basically the same results as this laptop. When the laptops are plugged in and the desktop isn't turned on, the wireless connection is flawless and never disconnects. When the desktop is turned on, both laptops stay connected for apro. 3-4 minutes until it disconnects for 1-2 minutes. After it disconnects it reconnects again. The screwed around with the NAT settings and port fowarding for 3 types of routers and get the same result. The problem is in the desktop, just not nessasarily sure what it is. I scan for virues and mal-ware but came up with nothing. I think it might be a type of program causing it or maybe a bad motherboard? My wired desktop stays on the whole time when it is turned on, No disconnects.
  12. Hmm, this is a tough one because there's no obvious correlation between the WIRED desktop and the dropping of the WIRELESS laptops.

    The only thing that comes to mind is if the desktop is somehow causing interference. Are there ANY other wireless devices on that desktop that could possibly be using the same 2.4GHz frequency, such as a wireless mouse? Bluetooth adapter?

    Remember, there are a lot of devices, some not even related to computers, that share the 2.4GHz band. So if there’s ANYTHING about that desktop that triggers another 2.4GHz device (maybe even some device you least expect), that could be the cause, esp. if the desktop is particularly close to the wireless router. It would even be interesting to see what happens if you moved the router further away from the desktop and MUCH closer to the laptops.

    Come to think of it, have you tried other wireless channels?
  13. From channels 1-11.. and with my belkin router even channel 1-13, all tested and still disconnects. I am going to try unpluging my mic and webcam maybe that might do something.
  14. Bump.. _-_-
  15. Just a thought, could it be that bandwidth being used by the desktop causes inadequate signal to be sent via the wireless router to the laptops. If this could be the cause, then I would suggest that you invest in a small 5 or 8 port switch The switch connects via 1 ethernet cable to port on the switch, then connect all of your PC's directly to the ports on the switch. Nothing else should be plugged directly into the router except the switch. The switch will "direct the traffic" in such a way that all of the PC's connected to the switch will receive the "full" speed and strenght . Again, its just a thought !
  16. NOTE: The same bandwidth problem could apply if all of the PC's are directly connected by cables to the Router as well . Especially if the router is is an older one.
  17. I am also having the same problem
  18. you have change everything but laptops , maybe something is wrong with laptops 's wireless Driver or an Special property on the Advanced Tab of it.
  19. Log into the router, can you see unique MACs and IPs for all 3 computers? Are there any logs for the router to give you clues?
  20. OK after weeks of this, I figured out the problem. The onboard eternet from my LGA 775 MSI MOBO is defective after windows vista updates. Updating and flashing bios did not help. Reinstalling windows vista did the trick, and when I download microsoft updates the problem starts again. Microsoft updates has always given me problems (my gigabyte mobo had problems with display when I downloaded last weeks updates and I had to system restore). Thank you to all the people that tried to help.
  21. i have the exact same problem... i tried restoring but the problem exists. any pointers???
Ask a new question

Read More

LAN Wireless Connection Desktops Ethernet Card Networking