Sign in with
Sign up | Sign in
Your question

Help with fixing the 9600GT

Last response: in Graphics & Displays
Share
January 28, 2010 9:48:13 PM

Hi there!

I've been having constant slowdowns of my graphic card. It's an XFX Nvidia 9600 GT, and it's about a year and a half old now.

Originally I had it installed on my older PC which had a very poor power supply, so maybe it was underpowered and got damaged in the process (I had booting issues with that PC). On my new PC, I have a good Corsair 650 watt power supply and everything is working fine, except the GPU which seems to get slower and slower every day, even tho on the software side of things nothing new gets installed.

I've eliminated pretty much every possible software problem. This includes trying out clean installations, different versions of drivers, different versions of operating system, different graphical configuration (vsync on/off etc). And I've checked my RAM for errors, which turns out Ok.

The only thing I can think of is that the GPU got damaged somehow from the underpowered PSU on the older PC. So I'm thinking maybe it would be a good idea to check if the capacitors are working fine.

Here's the pic of the GPU:



I've put a question mark there because I'm wondering why theres a hole for a capacitor and no capacitor in place. Is that by design, or could be some kind of manufacturing error? Also, how do I check if the capacitors are fully functional? Could I use one of those universal measuring tools to check the resistance or something similar?

I'll appreciate any help you can give me. Thanks for reading!

More about : fixing 9600gt

a b U Graphics card
January 29, 2010 12:09:33 AM

You might go to PCPitStop and run their free PC test and see what it says about your graphics card and how it compares to others.

http://www.pcpitstop.com/betapit/pitstop.asp

Or you could get some benchmarking software to check.

How long has it been seen you defragmented your HD? Perhaps doing that would help.

I don't have that card so I donlt know if the capacitor is missing - but I question whether such a thing, if it were true, would have a system of steadily eroding performance compared to a one time drop when it fell out - or just long term poor performance if missing from the start.

Does the problem exist accross all applications, both those that are graphics intensive and those that are not? How about boot time?

Do you have another graphics card you can install to check performance?
!