Sign in with
Sign up | Sign in
Your question

SD won't Format Won't read won't mout

Last response: in Storage
Share
February 6, 2012 9:53:32 AM

hello every one

i hope any one can help with this

last night i had my android phone restarting and then i got a message says the sd is corrupted so i paniced and removed it and hooked it to my pc running Windows 7 using a common card reader

it worked fine so i backed up the important stuff and while doing this i noticed alot of new sub folders with coded names ..... so yeah it was partly corrupted

so after back up i right clicked the partition > properties > scan disk ... for errors ( Auto fix checked , bad sector checked )

and after its done it says it got fixed even tho the log shows alot of files unrecoverable i couldnt careless since i backed up

now i look at my partition and its not fully mounted so i couldnt even double click it it asked for format it became RAW
it became 121MB (originally 4GB) and when i format it it just doesn't change


so i tried to recover it but got no where
i tried several softwares like panasonic and SD formatter
the Formatter said its write protected while i dont even have a protection switch in my reader

the cmd Prompt after format says its unusable ,and nothing changes

i went to the Drive Manager , and its there as RAW and still no any unallocated space or any thing just that raw partition

i tried to use mac drive to format it to hfs+ which is a hopeless try but still nothing changed to it

PLEASE HELP ? :|

More about : format read mout

February 6, 2012 10:02:10 AM

i'm sorry i just realized this is the wrong place for this thread , i hope mod notice it soon and move it , and thanks :) 
February 6, 2012 10:03:37 AM

Buy a new sd card,kiss old one goodbye.
Simples
Related resources
February 6, 2012 10:21:55 AM

Try a tool called Mini-Tool Partition Wizard. http://www.partitionwizard.com/free-partition-manager.h...

I cant promise that it'll work, but Windows has a hell of a time formatting SD cards, I had problems with my Micro SD card that I had in my Nook when i was rooting it and used that tool to wipe it back to normal. Also used the tool to successfully get back lost space on flash drives that windows didn't see.

But if that doesnt work sounds like you got a burned out SD card. Good luck
February 8, 2012 2:38:01 PM

sorry for delay , iam trying this software now

what i dont understand how could it burn if all i did to it was error scan how stupid is that !


Edit : i did every thing possible there nothing changed but when i did create a partition out of those poor 121mb it created a full used partition :| and still cant open it with explorer so i got no where :/ 

EDIT !! lol after ejecting it and reattaching it every thing went back as if i didnt format or partition so back to where i was i think yeah its burned :/  but why why why why xD
February 8, 2012 3:04:54 PM

It sounds a lot like it is write protected. On most standard SD cards there is a white switch that you can move to remove that. Otherwise it may be a setting the manufacturer has in its own software. I had this exact issue happen with a flash drive I had at work. I would make changes, it would say they are successful but it never took. it took me a while to dig up the software, but once the write protection was disabled I was able to delete the partitions on the drive, create a single partition and it actually stayed that way. I hope that helps.
February 8, 2012 3:19:05 PM

well yeah the sd formatter says its protected but i got no switch on my reader or sd or any thing ,
and if u r right then how can i dig this software even tho i doubt its protected that way xD
the windows doesnt full read the card neither the cmd ;/ i even tried to format via phone it doesnt do any actions ..... if its protected pls tell me how to disable it
!