Sign in with
Sign up | Sign in
Your question

Problem getting SSD to run at rated speed

Last response: in Storage
Share
February 6, 2012 11:23:08 AM

I've been having trouble getting my Plextor PX-M2 Series PX-128M2S running at its rated speed. It is a 128GB sata III SSD. Its rated to run at 420mb/s read and 210mb/s write. When I first built the PC(built in late august of last 2011) it was really slow but I had to change it from ide to achi in the bios. After I did that it was around 375 read and 180 write. Then a few months later I notice that my boot time went from 21 seconds to 32 so I ran a benchmark and it was around 325 read and 120 write. I decide to do a fresh install of Windows 7 not only because of the SSD but also because I like to have a fresh every few months because Windows likes to just take up space the longer you use it. I wiped the SSD and then made sure everything was right in the bios(its in achi mode), made sure the cables are right and yes I'm using a sata III cable and the motherboard supports sata III. Then I did the fresh install, did some optimization and ran AS SSD Benchmark. Now its 320 read and 80 write. Not sure whats wrong with it. Some weird things I did notice were that in the bios it says the drive is ide, same with my optical drive which is also sata. Windows recognizes that it is a sata drive so I'm not sure what the bios is doing. Also there is a option in the bios to either run that sata ports at sata II or sata III speed or auto. I have it on auto because the optical drive is sata II but should I change it? can anyone help me get my drive running at its rated speed?

Motherboard is a ASUS M4A87TD/USB3 AM3 AMD 870 SATA 6Gb/s USB 3.0 ATX AMD Motherboard
February 6, 2012 11:41:03 AM

You should ensure that it is plugged into a SATA3 port and ensure that it is running at SATA3 speed for the best performance. Also you may want to figure out what benchmark was used by Plextor for their speed rating, as different benchmarks will return different results. Also Intel is known for having better SSD benchmark results with their SATA controllers, so you may be getting the max that yours has to offer.
m
0
l
Related resources
February 6, 2012 2:02:06 PM

It is in a sata 3 port and running at sata 3 speeds. I notice that in the bios it thinks that its using ide. I thought I had a up to date bios because my motherboard is less than a year old but it was out dated. I updated after posting this and at first it recognize the drive was sata but after the first boot it went back to thinking it was ide. That makes me think its a bios problem. Not sure why it think that everything in my sata ports are ide. Anyone have any suggestions?

Also here are the AS SSD Benchmark results

m
0
l
February 6, 2012 2:15:40 PM

lol my wild fire is a lot faster than that ... umm try running it only half full or take off any uneessary programs off the ssd and put them or install them onto a secondary drive. if you fill the drive up your going to take a performance hit
m
0
l
February 6, 2012 2:42:14 PM

Just reinstalled Windows 7 and I always optimize it when I first install it so nothing is on the drive it has 90Gb out of the 128GB left. Also I store all of my data on a external drive.
m
0
l
a c 523 G Storage
February 6, 2012 2:59:58 PM

Advertised speeds for your drive are with ATTO benchmark software, not AS-SSD.

ATTO uses highly compressible data to test Read/Write speeds.
AS-SSD uses highly incompressible data to test Read/Write speeds.
m
0
l
February 6, 2012 3:22:55 PM

Well I just ran ATTO and its about 400mb/s read and 165 write at some points using the default settings. One think that I don't like is that I ran a benchmark with AS SSD when I first built the computer and it was around 375 read and 180 write. Not sure if something change with AS SSD but I guess if its getting really close to the rated speed in ATTO its running ok. I just want to make sure my $215 doesn't go to waste. Although I still would like to know why it still thinks it a ide drive in my bios.
m
0
l
a c 523 G Storage
February 6, 2012 3:33:55 PM

The next time you do a fresh install, Secure Erase the drive first. Then test with ATTO after you've go it up and running.
m
0
l
February 6, 2012 3:38:22 PM

Got it. Thanks for the help.
m
0
l
!