Sign in with
Sign up | Sign in
Your question

[SOLVED]BIOS Can't Detect SATA Hard Drives...CAN Detect SATA DVD Drive

Last response: in Storage
Share
February 7, 2012 4:00:13 AM

Hello All :) 

Here's the Short of it - My BIOS does not detect my old and new WD 500GB Hard Drives. It does not detect my old or new 1TB Seagate Barracuda drives. It DOES detect my 180GB Hitachi Desktar which I found in the trash (see the Long of it :)  - It DOES detect my ASUS DVD Drive. I am temporarily using the Hitachi as my boot drive until I can get to the bottom of this. Because BIOS cannot detect them, I cannot install windows to them or use them as backup storage.

Windows does not detect the hard drives neither, however, if I go to the device manager and scan for changes, the HD's will sometimes pop up, sometimes not. When they do pop up, the drive becomes available under My Computer and I can write to them. Unfortunately, they tend to not stick around for too long.

My system - Motherboard: Biostar H67MU3 Ver. 6.x with an i5 2500k - 8Gb of DDR3 - Windows 7 Ultimate x64 (Also tried Windows 7 Enterprise x86 at my job)

My steps - I have tried different SATA cables, checked every SATA port, tried removing all peripherals, tried IDE, AHCI and RAID settings from BIOS - Updated my BIOS, tried different hard drives singly as well as together. Tried different versions of my chipsets drivers. Started with the older versions that came on the install disc, tried Biostars more updated versions, tried intels even more updated versions. I tried seatools for the seagate and the data lifeguard for the WD's. But neither program could detect their respective equipment unless I get the device manager to show them. But since they only show briefly, any efforts to scan or test them are futile.

Here's the Long of it - I built the computer myself. At first I was using a 1TB Seagate as the boot drive with a 500GB WD as extra storage. It came to pass that the Seagate gave me the click of doom. It died a sad and horrible death (although I could still kind of access it with recovery software). As I had no extra money and the cost of hard drives is currently astronomical, I had to hold off on getting a new one. I couldn't use the WD as it was full of files I couldn't bear to part with. I attempted to use a copy of a Knoppix disk I had just to get by. That's when I found that the WD was no longer being recognized. I figured it had become corrupted or something.

In the meantime, while throwing out some trash, I happened to spy a discarded mini-pc in the dumpster. I pulled it out and checked to see if the hard drive was still in there. It was, and more importantly it was a SATA (my mb does not have any PATA ports) - I hooked that up, installed windows to it with no problems (other than a strange dislike of my sound card) - Once that was up and running, I put the WD back in to see what I could see. No joy.

By this time, I was able to go pick up a new HD. Due to shortages the only ones available were 1TB Seagate Barracudas. I picked one up and put it in the computer and attempted to copy the Hitachi's partition to it. That's when I found out the drive wasn't being detected. I tried various ways of troubleshooting. No joy.

I tried to install directly to it with my Windows disk. According to Windows, the drive cannot be written to. According to BIOS, the drive doesn't exist. I figured I had a faulty Barracuda...there's a lot of em out there. I took it back and picked up another WD 500GB. This drive wasn't detected by BIOS neither.

So the round up is 2 WD's and 2 Seagates undetectable by BIOS - 1 Hitachi and 1 DVD drive detectable with no problems.

After some research I found out that intel reported an issue with its 6series chipsets where the SATA ports degraded over time. But this was supposed to be fixed in the B3 versions of the hardware (which I have). Also, it completely boggles my mind that drives that were previously detected are no longer detected, yet this Hitachi I happened to find works perfectly, and the DVD drive never had an issue.

I just can't figure it out. Especially since it wasn't an issue before. Anybody come across a problem like this?
February 8, 2012 12:13:24 AM

Today I tried to remove the SATA controllers from the device manager and reboot...just to see what happened. This caused even the Hitachi to not be seen by bios but the DVD drive remained. I used an old Hiren's Boot CD I had to get into mini-xp. From there I was able to see my 500GB WD. I used some of it's tools to make sure the drive was good. I activated a partition on it, downloaded the intel chipset drivers and installed them to the mini-xp installation. Reboot.

After the reboot...same thing. The Hitachi was found and still worked as a boot disk but the WD drive still would not show in BIOS and Windows 7 still can't install to it. "Windows cannot be installed to this disk"

I'm probably just gonna give up and get a new motherboard. Maybe one of those Z68 ones.
m
0
l
February 18, 2012 2:48:09 AM

No help huh? Well...it bees like that sometimes :) 

Anywho, I got this one RESOLVED! In the end, I found out it was simply a bad power supply. That's the answer.

...here's the long version. The computer started random shut downs that became more frequent. I suppose that was a dead giveaway. However, I thought it was because I was mixing in so many different drivers during my troubleshooting that I had a conflict. I actually wanted to test the power supply but was too lazy. A few days ago I decided to finally go find my old tower from a previous build and dig out the 450watt power supply on it. One of the sata connectors on it was broke (it only had 2, and 2 patas) - luckily, I had a few pata to sata adapter pieces. Hooked it up and boom! The new Western Digital was seen in BIOS immediately. I hooked up the original Seagate and the other WD and both were recognized as well.

Further, once the 450w power supply was hooked up...the 1TB Seagate stopped clicking :/  I haven't ran a diagnostic on it yet, but I currently have full access to it with no issues...go figure. Unfortunately, since I treated the files on it like a fire sale when it first started clicking, I mangled the operating system so it can no longer be used as a boot drive (nor would I want it to be...that's just too much to lose!) But I'm just happy all my stuff is intact (currently being divided up between the 2 500gb WDs :) 

I suppose in the end, the smaller Hitachi drive and the DVD burner didn't require as much power as the bigger HD's - or something...

So there ya have it. I'm gonna order a new power supply when I get a chance. And after all the research, I'm still thinking about getting a new Z68 motherboard for my I5 2500k
m
0
l
less than a minute ago

Hi,

i also have some problem like that!! bios can detect dvd driver and cant detect sata harddisk!!

i have to tried change other HDD ,sata cable

my system is asus p7h55-m i3 LGA1155

anybody help!!
m
0
l
!