Hd5770 doesn't work only get beeps

Hi

I just bought a new power supply and graphic card for my system (ocz modxstream-pro 500w and hd5770 sapphire vapor x).

I installed my psu with old card (7600GT) and no problems, the system boots normally. When i install the hd5770 and try to start up i only get some beeps (like 7 or 8 or something) but nothing else, only all the fans or going to blow hard.

as far as i know i installed the card correctly with pci power supply.

motherboard: fujitsu siemens d2587-a1
chipset: intel Q35
processor: intel core 2 quad q6700

can someone help?
5 answers Last reply
More about hd5770 doesn work beeps
  1. Did u connected the 6pin power connector cable for your card?
    u can read on your manual to get what meaning by that beeps... :)
  2. Quote:
    i know the problem... You've incorrectly connected your GPU power supply. The computer doesnt start to help protect your graphics card


    what could i have installed wrong then? the pci e power connector? my 7600 gt without pci e power does work. the 5770 does also work in an other computer.

    i don't have aan manual for the motherboard
  3. My radeon 5850 did the same thing when I built my computer. I forgot to connect the power to the 5850 and the computer simply beeped a whole bunch when I powered it up. Try connecting (or reconnecting) the power to your radeon card.

    It may also be that the 500w power supply is getting stretched a little thin, and can't supply enough power to the system with the radeon card installed. The radeon cards are a beast, and require quite a bit of power.

    I would start by checking the power connectors on your card.
  4. timmaciejewski said:
    My radeon 5850 did the same thing when I built my computer. I forgot to connect the power to the 5850 and the computer simply beeped a whole bunch when I powered it up. Try connecting (or reconnecting) the power to your radeon card.

    It may also be that the 500w power supply is getting stretched a little thin, and can't supply enough power to the system with the radeon card installed. The radeon cards are a beast, and require quite a bit of power.

    I would start by checking the power connectors on your card.


    i reconnected the card several times but no effect. recommended for hd5770 is 450 watt so it's not like that could be the problem. could it be a bios/chipset problem??
  5. I borrowed a GTX 285 to test with an other card en this one does work (pc starts up without problems). Could it be because the hd5770 is a new card or something (directx 11?).
Ask a new question

Read More

Radeon Power Supplies Graphics Cards Graphics