Sign in with
Sign up | Sign in
Your question
Solved

Catalyst Overclocking Issues

Last response: in Overclocking
Share
October 25, 2012 3:06:06 AM

Hello,
I have an AMD Radeon HD 6770 GPU, and whenever I overclock it to the maximum settings (GPU clock 960 MHz, Memory clock 1445 MHz) from Catalyst Control Center and play a game, it first runs smoothly but after about 15 seconds, the screen blacks out for 5 seconds, then returns to where I last left off. This cycle continues until I exit the game, about 5 seconds in between each cycle. When I turn overclocking off, the games run smoothly with no issues, but the fan speed usually increases to 80%-85% speed, and the noise just gets loud and annoying. What can I do to fix this problem? I appreciate your help.
October 25, 2012 3:39:12 AM

ya that is called instability some cards can go there and even beyond but your is still good also this a 6770 a LOW END CARD that really isn't meant to overclock this is more meant to be put in a DELL not a gaming rig
October 26, 2012 12:41:25 AM

Yes I know, but Catalyst Control Center is a device driver specifically made for AMD GPUs (the GPU and Catalyst came with the pc), and it should be able to overclock to any speed, even to the max settings, without any issues. I am not very familiar with AMD GPUs, so I am not sure if this sort of instability is normal with Catalyst. Is there a solution to this (other than not overclocking), or should I contact AMD? Any advice would be useful.
Related resources

Best solution

October 30, 2012 7:46:16 PM
Share

Your supposition that it should be able to OC to any speed is wrong. That software is made to manage a lot of different cards each of which have their own capabilities. Turn your settings down until you no longer get your black screen or other visual artifacts and that's what your individual card can do. It's important to note that even a single card can be different from others of the same model based on potential manufacturing defects, differences in the quality of various individual components, etc.
November 3, 2012 6:38:11 PM

Thank you for your advice. I kept testing the clocks and found that the high performance GPU clock was causing the problem, so I set it to 915 MHz, which is the highest speed without causing instability. The memory clock did not seem to have any affect while decreasing or increasing it, so I left it at 1445 MHz. For now, I think the problem is solved.
November 3, 2012 6:55:46 PM

Best answer selected by pwx.
!