WoW is lagging

I have 2 PNY 9800 GT's with 1 gb each and I still cannot play Wow at maxxed settings on 1680 X 1050 res. I installed nhancer and made sure wow was using my second video card but im still fps lagging. Is it just normal to lag with 2 of these video cards or is something screwed up.
12 answers Last reply
More about lagging
  1. Yes,
    Something is ...
    I wont say that.
    List the rest of the specs of your PC
  2. OS: Windows 7 64 bit
    RAM: 8 gb of ddr2
    Mobo: p5n32-e sli
    Chipset: nForce 680i SLI
    CPU: Core 2 Duo at 3 ghz
    Windows experience index score is 5.9
  3. Your PSU?
  4. Its a thermaltake TR2 RX 750 watt
  5. Something else is not right
    Check your Card on another PC
    and
    See if it plays good or lags as on yours
  6. I don't have another pc around but just a note im able to play left 4 dead 2 at maxxed settings easily and my temps are kinda bad at 60 degrees Celsius idle
  7. Have you updated the drivers?
  8. nVidia 196.21 forceware
  9. I don't know about the version
    Tell me is it latest?
  10. Yea came out the 10th of Jan
  11. Its something else
    Cant you check the card on any PC
    your brother, your friend
    That will tell us the working of the card
  12. I have another comp here but I don't wanna go through the trouble of switching PSU's at the moment. I'll get back to you later when I do. Thanks for the fast replies I really like this site
Ask a new question

Read More

Nvidia Graphics Cards World Of Warcraft Lag Graphics