Sign in with
Sign up | Sign in
Your question
Solved

USB Device not recognized!

Last response: in Motherboards
Share
September 12, 2010 10:32:05 PM

*not sure if this is a hardware or software issue so I am asking at both places*


Hey all,
I'm running win 7 64bit on a P6X58D premium mobo

I just build the computer and had a brand new SSD that i loaded windows onto. now none of my USB stuff will work
mouse/keyboard/thumbdrives/anything
none of them work, but when I plug them in windows detects them and just goes right away and says that they dont work (usb device not recognized)

I've tried updating windows, disabling usb in the bios, turning off and unplugging and waiting a few minutes, installing all the drivers I can find for usb, nothing seems to work.

Please let me know if anyone knows whats going on and how I can fix it! thanks!!!!

More about : usb device recognized

Best solution

a c 716 V Motherboard
September 12, 2010 10:58:29 PM

First, disconnect all USB devices and go in the Device Manager and open the Universal...controller and uninstall all the items and in particular the Hubs and Controllers and restart. They will automatically be reinstalled fresh upon restart.

I ASSUME that you didn't install ANY of the Windows 7 32-bit drivers; meaning that you need to select Window 7 64-bit from the driver selection.

Next, after restart connect one {1} at a time each USB device. If it fails then open the Device Manager and find the {Device} in the tree and select untinstall then scan for new devices. Have ready ALL to the device drivers extracted and ready on the SSD/HDD IF Windows cannot find the correct driver and if it cannot then manually select the "Have disk" option.

The reason for Uninstall vs Update is it forces Windows to actually reinstall the device and "should" also in doing so "fix" any bad associated registry entries.

Worst case - If you okay with it then I'd first disconnect all of non essential peripherals and Clear CMOS.

Good Luck!
Share
September 12, 2010 11:35:08 PM

Thanks for the response Jaquith. I tried everything you said and no dice. I uninstalled all of the usb devices including busses and controllers, and restarted and it re installed the controllers automatically and when i plugged in a device it still did the same thing, didn't work
I tried clearing the cmos and that did not fix it either:(  I think im going to re install windows and see if that helps
m
0
l
Related resources
a c 716 V Motherboard
September 12, 2010 11:50:28 PM

How are you connecting the USB devices? The rear of the MOBO, Case USB or a USB HUB?

Reasons:
Case USB - if you accidentally mis-wired the connections {damn things are small}
USB HUB - In sufficient power.
{BIOS - some USB K/B or mice require the BIOS to be updated}
{USB 3 device in USB 2 won't work}
m
0
l
September 13, 2010 12:05:24 AM

I've tried every port, case and mobo, then i installed the expansion slot usb card just to see if that would work as well:( 
I did just update the bios as well, still no joy!
m
0
l
a c 716 V Motherboard
September 13, 2010 12:16:17 AM

Then next I would do is to either unplug + remove the CMOS battery for ~ 15 minutes <or> Load Defaults in the BIOS and re-flash the BIOS**.

I agree it is bizarre?! So if I understood correctly, before the SSD, the USB devices "did work" at sometime and prior to the BIOS flash? **You can rollback the BIOS to a prior version.

Q - just to understand, why did you update the BIOS?
m
0
l
September 13, 2010 12:39:07 AM

oh the usb had nvr worked, just built the computer and right off the bat the usb was a no go. I read in other places online that a bios update might fix it so that's why I did that.
i just re installed windows and still no usb, going to try the battery thing
m
0
l
a c 716 V Motherboard
September 13, 2010 12:51:36 AM

BTW - I have the P6X58D-E "now" on my pseudo WS's after RMA'ing 10 GA-X58A-UD3R (rev. 2.0) and no USB issues.

Meaning it's always something, and you're doing ALL of the right things so if above fails you may want to consider RMA'ing the P6X58D Premium.

I assume it's ALL clean and without ANY of the ASUS "Utilities" installed; if not remove them. Also, I assume there's no User Account w/password {yet} and you starting right into Windows as Administrator. You also, can try MSCONFIG and load Diagnostic.

//Last post for the night

Good Luck!
m
0
l
September 20, 2010 4:21:13 AM

Best answer selected by 3nn10.
m
0
l
!