Sign in with
Sign up | Sign in
Your question

Ati2vag and ati2dvag errors

Tags:
  • Radeon
  • Graphics
Last response: in Graphics & Displays
Share
January 30, 2010 5:32:57 PM

I am having some very frustrating computer problems, and I hope that someone here has a solution. First off, I appreciate anyone taking the time to sort through all this. I'll try to be brief and as complete as I can; if you need more, I'll get it for you.

I began having some problems with my computer a few months ago. When scanning web pages, I would occasionally begin seeing artifacted pixels. Wherever the window was updating (scrolling down, etc) this artifacting became more and more pronounced until either the entire desktop or the individual window went completely scrambled. The system would lock up shortly thereafter and require a reboot. Since the problem was not crippling, I would just reboot and continue what I was doing before. It might be germain to note that 3D intensive games like Sins of a Solar Empire, Thief 2, Empire Total War, Freelancer, Neverwinter Nights, etc. had no problems that I can remember.

Time goes on and I begin to notice that I have a problem. The artifacting continues to happen and the reboots become more frequent. Since (to me) this looked like a degenerating problem, I figured that there might be something going wrong with the video card itself. That perhaps it might have a defective chip, or something. When I first put my computer together, I purchased two Powercolor 4870 HD ATI Radeon 512MB cards, thinking I would crossfire them together; but, this proved incompatible with my ASUS P5N-D motherboard, so while all of this was going on I had a spare video card in a box in my closet. I pulled the card out of my case, and replaced it with the spare. In short order the problem cropped up again.

I tried to update my drivers, but there was an installation error. After fiddling with it for a day, I made the decision to reboot and reinstall everything - a bit dramatic, I know, but a fresh start isn't all that hard to manage. I reinstalled my OS, after a complete reformat. Windows XP x64. I put on the drivers for the motherboard on (from CD). I put the video card drivers on from the CD. It wasn't long before the problem happened again.

Okay, I'm going to speed this story up because I don't want to waste your time. At the suggestion of a Best Buy Geek Squad guy I have rolled back and re-installed Windows XP (not x64) on the system. Now the lockups have one of two possible errors:

One is where the screen goes to a very low resolution and color depth, and after a lot of lag the following dialog box pops up:
"The ativag display driver has stopped working normally. Save your work and reboot the system to restore full display functionality. The next time you reboot the machine, a dialog will be displayed giving you a chance to upload data about this failure to Microsoft"

The second is where a Blue screen comes up and says that ati2dvag was in an infinite loop and to prevent damage to my computer it is shutting down. It does a physical dump of memory and that is that.

After these recent crashes, when I reboot, I get a screen before the XP loading screen that says:

"Windows could not start because of a computer disk hardware configuration problem. Could not read from the selected boot disk. Check boot path and disk hardware. Please check the Windows documentation about hardware disk configuration and your hardware reference manuals for additional information."

Okay, now let me get you my specs. Thanks again for taking the time to offer any suggestions.

OS: Windows XP Professional (I also have XP x64 if that would be better)
CPU: Intel Pentium III Xenon processor, 3166MHz
Motherboard: ASUS P5N-D
Video Card: ATI Radeon HD 4870
Hard Drives: 2 Western Digital (320 GB and 500 GB)
Power Supply: Antec Earthwatts 650 W

I know this is a tangled mess. Thanks for your insight.

More about : ati2vag ati2dvag errors

January 31, 2010 5:56:50 PM

Come on... nothing?

I would even accept something radical like yet another reinstall.

I've updated to the latest ATI drivers, I've even tried the Omega Drivers.

What am I doing wrong? Does anyone have any ideas at all?
m
0
l
January 31, 2010 6:00:19 PM

Found this over at:

http://www.techspot.com/vb/topic15393.html

"Here we go folks, I've been having this problem for almost a year now with my computer (infinite loop and ati2dvag.dll reboot errors), and tried almost everything my mind could possible think of doing. I've tried every solution on this board, and every other board I could find relating to this file and to the infinite loop, with absolutely no success. I tried every driver package available, bios updates, agp chipset updates, every combination of every setting. I've tried reducing power usage in my computer, I've placed more power in my computer... I've added more fans and created an optimal cooling system in my computer. I made sure there were absolutely no IRQ conflicts, and nothing was using the same IRQ as my video card. I've tried with one stick of ram, with one in 1 and 3. I've tried disabling onboard sound, and putting in a soundblaster card. Nothing... I mean nothing, worked at all.

Until now! I found a solution, that has worked for me and a bunch of other people who have tested it for me.
So give it a try, perhaps it will work for you too. My computer has been working 100% since I made this change.

Right click-mouse over My Computer
Properties
Hardware(Tab)
Device Manager(button)
Click [+] next to System devices
right-mouse on CPU to AGP Controller (or whatever your controller is called, mine was SiS AGP)
Update Driver(button)

Select Install from a list or specific location (Advanced)
Next(button)
Select Don't search. I will choose the driver to install.
Next(button)
Select PCI standard PCI-to-PCI bridge
Next(button)
Finish(button)
Reboot."

I tried this, but I don't know which entry in my system devices is my CPU to AGP Controller, so this step I could not do. I did the PCI to PCI bridge. Still having the same problem.
m
0
l
Related resources
February 1, 2010 7:42:22 PM

Really? Nothing? No one has any suggestions at all?

Does anyone know of a web site where people can go to get help with hardware problems?
m
0
l
February 1, 2010 9:23:51 PM

Considering the amount of times I and many others have been told that this problem either does not exist or that if it did it was fixed ages ago, I can kind of understand why people are loathe to respond to your pleas.
m
0
l
February 2, 2010 10:57:27 PM

Well, I called ATI support and spoke with a tech there who said that the error message could be caused by a number of different problems, and that it is not indicative of a specific problem. He suggested memtest86, Prime95, uninstalling ATI drivers, using driver sweeper and then re-installing the ATI drivers (or even downgrading to an older driver), and updating my motherboard drivers.

The first and easiest thing to do was to get rid of the new ATI drivers and install older ones.

I followed up by updating my motherboard drivers.

I actually thought that it was fixed for awhile. My computer was going nearly an hour before it started getting corrupt. I take that as a good indicator.

As we speak, memtest86 is running on the crippled computer. I doubt that will reveal a problem, but due diligence.

After this comes Prime95.

I can understand that some folks out there have had this problem before and believe me I understand how frustrating it is. But those who have had the problem either still have it and reboot their computers every 15 minutes, or they have figured out a way around it. Mousemonkey, you said that you've had this problem, too; do you still have it? If not, what did you have to do to fix it? I expected the folks here to have a suggestion (even if it was "buy a new video card"). I've been quite frustrated with this problem, and I am disappointed by the total lack of help here.

So, I'm going to document my own battle with this windmill. Maybe what I have to say may help someone else who has to go through this. Maybe I'll just fail. Who knows?
m
0
l
February 2, 2010 11:22:59 PM

binary_spider said:
Mousemonkey, you said that you've had this problem, too; do you still have it? If not, what did you have to do to fix it?

I never did find a permanent fix and have only used Nvidia cards in the last four or five rigs of my own, and rigs I've built using an ATi card have been stable and shown as working when the customer has collected them.

Then when I get a phone call or email complaining that it's gone tits up after updating the driver I tell them to either roll back the driver or boot into 'Last Known Good Configuration' which usually seems to work because they go away and stop phoning me.
m
0
l
February 3, 2010 1:28:35 PM

I ran memtest86 yesterday for two hours, no problem.

I ran Prime95 all night. Woke up this morning. No problems.
m
0
l
February 7, 2010 2:19:44 PM

Okay, you're reading this, so maybe you're someone with this particular problem. Here are the fixes I've run across (some folks claim to have these solve their problems).

First off, check your power supply and make sure it can give your card enough juice. Oh, and you don't want to be the guy who spends a week pulling his hair out and then realizes that the card wasn't plugged in all the way. If your power supply and cables are good, keep in mind that it could be malfunctioning, but get to that later.

Next, go to your mobo manufacturer's web site and look at what they have in the way of drivers for it. Is your bios the latest version? Get that updated. Still crashing? Read on.

Turn off "enable write combining". Go to Control Panel -> Display -> Settings -> Advanced -> Troubleshooting. See if that helps.

Another possible fix is to disable a component called "fast writes". This is a little tweak, and it's primarily for AGP (not PCI or PCIe) cards. At this point you should still have drivers you either DL'd or got off the manufacturer CD, so there's a good chance you have their control center shell available as a right click item on your desktop. You may want to Google "fast writes disable" for a better explanation of how to turn it off, because you can do it through the BIOS or through software depending.

Go to the ATI website and look at the available drivers for your card. Pick out an older driver and DL it. Reboot the computer in safe mode (by holding F8 while the computer is booting up the OS) and completely uninstall all of the drivers and chipsets you have. Totally remove them. Install the older driver you just DL'd and reboot your computer. Still having problems?

Reboot again and start up in safe mode. Uninstall the drivers (old or new) completely AGAIN, but this time instead of using the ATI setup .exe, install the drivers manually. You can do this through the add hardware wizard. What you're doing now is avoiding the setup utility and installing just the driver through Windows. Still with me? Sorry. There's more.

I posted this next fix already, but here it is again for those who have the components. Check out your CPU to AGP controller driver. Right-click My Computer -> Properties -> Hardware -> Device Manager -> Click [+] next to System devices -> right-click CPU to AGP Controller -> Update DriverSelect -> Install from a list or specific location (Advanced) -> Next -> Select Don't search. I will choose the driver to install. -> Next -> Select PCI standard PCI-to-PCI bridge -> Next -> Finish -> Reboot.

Eh? No? Alright.

At this point, you might want to consider DL'ing Omega Drivers. They are a mishmash of ATI drivers, and they totally didn't work for me, but give them a shot. DL the drivers, reboot in safe mode, uninstall the drivers you've got now totally (as you've done before) and install the Omega drivers. Reboot. How about now? Any better? No?


Do a Google search and try to find EVEREST home edition. This is a "a freeware hardware diagnostics and memory benchmarking solution for home PC users, based on the award-winning EVEREST Technology. It offers the world's most accurate hardware information and diagnostics capabilities, including online features, memory benchmarks, hardware monitoring, and low-level hardware information." DL it, run it, take a look at the results. If it detects a problem with a component, you should be able to find it.

DL memtest86 and make a floppy from the utility. Reboot your computer and let it run RAM sequences all night long. If it's still running in the morning, your RAM is probably not the problem, so move on. If you want to be thorough, you can DL Prime 95 and let it run for another night. Neither of these is going to fix the problem, but if they fail, then that might let you know that there is a bigger problem you need to address. If they ran cleanly, then get out your compressed air and read on.

Turn off the computer. Pull your video card out. Is is dirty? Blow the dust out of it. Does the fan turn freely? Take a look at your mobo. Any visible damage? Blow out the socket. Blow the dust out of the case. Is there a way to consolidate cables and increase airflow? I don't need to tell you that heat is your enemy, but it is helpful to keep that fact in mind and give your setup a fresh look.

I'll post this now and then get back to you with some more ideas. I hope that one of these worked for you. If you've found other fixes, please post them. Thanks!
m
0
l
February 13, 2010 4:43:02 PM

After my last post I came across something someone said on another forum (http://www.hardwareanalysis.com/content/topic/31775/?o=...) about this problem:

Quote:
I've been through about every step imaginable.

I've changed my IRQ settings.
I've got the newest Catalyst Drivers.
I've got older Catalyst Drivers.
I've tried DNA Drivers.
I've removed the Card, cleaned it off and reseated it time and time again.
I've checked RAM.
I've reinstalled Windows.
I've used Service Pack 1 only.
I've used Service Pack 2.
I've got rid of Spyware, Viruses and all the rest of it.
I've formatted D:\ (My XP Installation Area)
I've deleted all the old drivers from my machine.
I've removed the side panels.
I've added fans.
I've replaced fans.
I've replaced heatsinks.
I've updated the Motherboard Software.
I've tried different settings.
I've tried underclocking.
I've tried 3 types of overclocking program.
I've explored the avenue of 2D/3D settings.
I've halfed my Aperture.
I've turned on and off VPU Recover.
I've reset the primary graphics driver to AGP.

...77 more 'Solutions' and I can write the book of "101 Ways to Kinda Fix your Computer".
m
0
l
March 24, 2010 4:13:40 PM

I know this thread hasn't had a response in over a month... First off, thanks for your posted solutions binary_spider. I have been through a very similar situation:

I work in a shop with about 70 workstations. We use Dell Optiplexes and Precision mobiles.

We use triple monitor setups with ATI cards, the Optiplexes have a secondary PCI adapter (also ATI) to run the third monitor.

3 users have reported similar issues, with varying degrees of severity.

I picked the worst case to start with, this is where it gets weird!

First step: Troubleshoot and update drivers and software to current versions. Event logs look ok.

Fail!

Second try: Reinstall OS (XP) with current updates and drivers. Recreate user's profile.

Fail!

Third attempt: Replace machine with new Optiplex 740 (existing machine was also a 740)

Fail!

4th: Replace primary and secondary card with a new matching Radeon 4000 series PCIx (16x and 1x).

Fail!

5th: Ordered a new computer for another user and diverted it to this user. Different model (Opti 760) and used factory installed XP image (I hate factory installed images!) Also discovered that MS mouse was preventing the power save and screen saver, replaced it with a wired mouse.

Fail! (Took a while though!)

6th: Had another workstation order placed for 3 new users and diverted one to this user (Opti 780 this time) Ordered new secondary PCI for third monitor.

Fail!

7th: Unchecked "Enable write combining"

Waiting to see if problem comes back.

Bottom line: New equipment (except for monitors, which I'm seriously considering), new Windows installation, new user profile, updated (and different) drivers. Same, exact problem! Same exact user!

Configuration matches all other users.

This is frustrating. Any insight would be appreciated and no expectations for a solution.

m
0
l
May 18, 2010 3:52:40 PM

well i scrathed my head for 2 months and found my solution....

IF U DONT WANT TO READ MUCH OF MY DESCRIPTION U CAN READ MY BRIEF SOLUTION FOR THIS PROBLEM AT THE BOTTOM.......

actually i bought a new system and faced the ""ati2dvag"" problem on the first day itself...just 2 hours after operating the system and started gta4 and there it goes the same problem...
I tried almost everything....i visited several forums...tried everything mentioned in the internet like updating,,downgrading,,changing the power from higher to lower....every driver i could imagine i updated...the problem would happen when playing intense games and browsing the net.....I gave up and changed the graphic card to NVIDIA 9400GT and i had no problem with that.

when i inserted my ati radeon hd 4650 the problem prevailed..

FINALLY I UPDATED MY BIOS from the intel website and the problem didnt solve.....while doing this i had my ati radeon graphic card inserted in my system.....

next time, i removed the graphic card and uninstalled my ati radeon drivers.....and i ran my system without the graphic card......means i had installed drivers for the on board graphics and my system worked on the onboard graphics......

NOW AGAIN I UPDATED THE BIOS FROM THE INTEL SITE......it was the same version i tried before which was not successfull.....
my system bios was updated.............now i inserted my graphic card......uninstalled my on board drivers and installed the ati radeon drivers
FOR MY SURPRISE THE PROBLEM GOT SOLVED AND AM NOT FACING IT SINCE 2 MONTHS........

<<<<IN BRIEF MY SOLUTION WAS UPDATING THE BIOS WHEN THE GRAPHIC CARD WAS NOT INSERTED INTO THE SYSTEM....AND INSTALLING THE GRAPHIC CARD AFTER UDATING THE BIOS>>>........thats it.

FOR MORE COMPARING AND CLARIFICATION MY SYSTEM SPEC ARE AS BELOW

I have a CORE I3-530
INTEL MEDIA SERIES MOTHERBOARD BOARD DH55TC
4 GB DDDR 3 TRANSCEDND RAM
2-500 GB SATA HARDDISK-SEAGATE
550 WATT MRON
ATI RADEON XFX HD 4650 1 gb GDDR2
A DVD COMBO DRIVE

m
0
l
December 1, 2011 4:02:38 AM

Hi!

I'm trying to solve exactly the same problem on Lenovo R60 laptop (9461-DXG) running Windows XP Pro SP3 with the latest drivers and software from Lenovo. It has built-in ATI Mobility Radeon X1400 videocard (128MB DDR, extendable to 512MB via Hypermemory technology), 2 GB RAM 667MHz DDR-2 (2 x 1GB), T5600 Core2-Duo (1.83 GHz), 100GB Toshiba HDD. Just to mention that dots, followed by blue screens with ati2dvag errors were occuring after fresh reinstall of the factory image (via Lenovo system recovery). Upgrading the drivers didn't help at all.
So I decided to go my own way. After replacing the SODIMM RAM modules (no effect), removing, cleaning and reinstalling fan assembly (common for CPU and videocard), vacuum-cleaning the motherboard - the only effect was lowering the CPU and videocard temperature by 2 degrees (54 ->52) Celsius and fan speed went down from approx. 2900 rpm to 2750-2800 rpm. The random dots on the screen were appearing almost immediately after logon.
However what surprised me first in the HWInfo32 diagnostic screen was the x1400 video RAM clock was set to 337,5 MHz whereas I found in the Internet this chip should run own RAM at up to 250 MHz. I don't know how Hypermemory works borrowing memory from the system RAM when needed, but it runs at 333 MHz (DDR2-667). Maybe I'm wrong, but this raised a red flag for me. I checked the clocks in three available Powerplay options in ATI Catalyst Control Center:
1. Optimal Performance (default when running on AC power):
GPU: 391,5 MHz, GPU RAM: 337,5 MHz
2. Balanced
GPU: 324 MHz, GPU RAM: 130,5 MHz
3. Optimal Battery Life
GPU: 128,5 MHz, GPU RAM: 130,5 MHz

Belive me or not, but since I set Powerplay to Balanced mode everything runs fine. No dots, no ati2dvag blue screens (infinite loops), black screens, reboots, etc.

I'm not a gamer so this video performance decrease is not important and I'm happy.
However the question is still there. Is ATI Mobility Radeon X1400 running factory overclocked by ATI or Lenovo? The problem with laptops' ATI cards is there are no downloadable drivers from AMD/ATI.
The only official drivers are available through Lenovo System Update. And I'm using them.
m
0
l
Related resources
!