Sign in with
Sign up | Sign in
Your question

My 2TB external hard drive isn\'t recognized by my computer now

Last response: in Storage
Share
February 10, 2012 6:12:19 PM

I've had my 2TB WD external hard drive for about 6 months now with no problems whatsoever, until now. I had to take my laptop apart to fix the keyboard, which entailed me taking out the disk drive. So I got everything back together, it seems the disk drive is resetting or whatever, but my WD drive is lagging like crazy. When this first started the drive showed up and I could access and watch the video I have in the first set of folders, but when I went to the subfolders it just lagged and became unresponsive. I figured that it just had to go through and recognize the files and so I left it overnight. Today I checked it out and I could again access the video and it would go to the first subfolder but when I tried to access another subfolder it again became unresponsive. Then after unplugging it and restarting a few times my laptop wouldn't recognize the drive. It did say there was something there but not the usual MyBook:K that usually comes up. So I did some googling and went into disk management. The drive showed up on there, but when I tried to change the drive letter it said that it wasn't there and to refresh. I went to refresh, but with the drive plugged in, it took forever so I finally unplugged it and BAM refreshed (this goes for everything I try, if it is taking a long time and I unplug the drive it instantly comes up before closing). I also tried out my 500GB drive and that works just fine. So can anyone help me here? The drive was fine before I fixed the keyboard, but now it seems to be degenerating or something.
a b G Storage
February 10, 2012 7:07:02 PM

I am more inclined to think you may have bumped a ribbon cable to the USB port. Bad connection causing lack of power to the drive. The 2T drive may draw more power than the 500GB. Check your internal connection.
m
0
l
February 10, 2012 7:14:56 PM

Thanks for replying, I just checked all 3 USB ports and its the same on all, it doesn't recognize the drive, and immediately after I unplug it pops up the message that the disk needs to be formatted, which would erase everything on the drive.
m
0
l
Related resources
a c 119 G Storage
February 10, 2012 7:20:09 PM

If you have everything connected the same way and the drive shows up in disk management then it could be that it has become defective and needs replacing. That is a senario that could be and even if the drive is only 6 months old it is possible. The hdd is a device that you just plug in and load files on to and unless there is a driver associated with it there isn't much that you can do with it.
When you went into disk management and saw the hdd there did it say that the drive was , healthy (active , primary partition)?
If you are able to access the drive through diak management then you could try to make another partition and have the files that are there on the one partition and make the second partition the rest of the space. Then see if when you put something on the second partition if it gives you the same problems.
m
0
l
February 10, 2012 7:20:56 PM

Also I forgot to say that when I fixed the keyboard the ribbons for the USB ports weren't exposed, they were completely covered.
m
0
l
February 10, 2012 7:23:47 PM

When I went into disk management the drive wasn't on in the top box but there was a space for it in the lower boxes, but it told me to refresh because it didnt recognize the drive. With the lag involved it would have taken a year to refresh it.
m
0
l
!