Sign in with
Sign up | Sign in
Your question
Solved

External Enclosure Drive Access Issue, Take 2

Last response: in Storage
Share
February 11, 2012 4:28:15 PM

Hello again,

I've recently bought an external SATAII to USB2.0 enclosure and was hoping to use my old laptop harddrive as a mobile storage. I've been having issues getting the computer to recognize and assign the drive, and I was hoping you might have an answer. I'm an intermediate user, so feel free to be technical.

---

Here's more info about my system before I go into detail about my problem:
OS: Win 7 x64 SP1
External HDD: WD 5400RPM 250GB SATAII ("HDD1") [with data and existing installation of above OS]
Enclosure: Vantec NexStar TX SATAII to USB2.0
Internal HDD: WD 7200RPM 750GB SATAII ("HDD2") [with data and existing installation of above OS]

---

So far:
1. I am running my computer through Windows 7 with HDD2 through the laptop SATA connection.
2. No issues with HDD1. HDD1 is not a brand new drive. It is working fine and was pulled straight from the laptop when I replaced it with HDD2. (Note: the hard drive I want to use in the enclosure still has the OS installed - let me know if this is the issue).
3. Plugged in the enclosure to computer using double USB cables. There is enough power to run the drive. LED is lit and steady.
4. Drivers installed successfully and the device is recognized. Shows up in the "Devices and Printers" as USB Mass Storage Device.

And here come the problems:
5. Device is not assigned a drive letter and does not show up in "My Computer"
6. Opened "Computer Management" and went to "Disk Management." HDD1 through enclosure is listed as "Disk 1, Unknown, Not Initialized." It is able to show the disk capacity, but says the space is "Unallocated." I know this is not true because it has partitions.
7. Attempt to initialize the drive to assign letter. Popup says "Cyclic Redundancy Check" for both MBR and GPT options.
8. Attempting to change the drive to "offline" also returns the "Cyclic Redundancy Check" error.

I have done steps 4-6 with the device policy under both "Write to Cache Disabled" and "Performance" modes. This also occurs when I am running Windows 7 using HDD1 through the SATA connection and trying to setup HDD2 as the external.

---

I sent my old one enclosure in and received the replacement, but this did not resolve the issues.

I have also tried it with a HDD which contained a previous installation of Mac OS X (10.5). The drive was recognized, showed up as "Healty" and "Initalized." I wasn't able to make it into a dynamic drive (probably because of the Mac OS data format) and assign a letter since it didn't have any recognizable volumes, but the Disk Management console was able to show the distinct partitions.

---

This is where I'm stumped. I'm starting to think it is giving me errors because I have not reformatted the drive and it still contains an OS. I prefer not to reformat because there are a few software installations I still actively use and have not been able to reinstall on the replacement hard drive. What are your solutions?


a b G Storage
February 11, 2012 6:45:14 PM

I wish I could offer the explanation for this phenomenon which is quite intriguing, but I'm afraid I can't.

Let me see if I understand the situation. The partitions on your drives play "now you can see me, now you can't" with you, because the enclosure doesn't recognize the partitions for some reason. Well, thank God the "now you can't" phase doesn't prevent the "now you can" phase, for one.

If I were you, I'd cut through this knot by putting HDD1 into the laptop, copy all the data to another computer over the network, then putting in HDD2 and copy the data back, maybe directly to the HDD1 which was put into the enclosure and partitioned/formatted from there.
Well the problems I can see:
- you need another computer with required space
- you have to arrange for those software you haven't migrated yet

Well, that's all, not much help I know, but at least you don't feel alone till someone more knowledgable comes around. ;-)
m
0
l
February 11, 2012 8:07:49 PM

Thanks for your response.

Kind of, but not quite. It recognizes partitions on the harddrive with Mac OS X installed, but does not recognize partitions for neither HDD1 or HDD2 which have Win7 OS installed. This is why I suspect that the existing Win7 installation may have something to do with the computer not being able to see the partitions. I am wondering why I can access the partitions when one type of OS is installed while not another; this is the main fault I am trying to overcome.

Everything worked fine when I formatted the harddrive with Mac OS X, but I've got data on HDD1 that I'd like to keep.

When it comes down for it for my use, it isn't really an issue of space but of functionality. I've got 400GB free on HDD2 which I currently operate from, and the harddrive I want to turn into an enclosure is only 250GB. I just want the ability to be able to boot from HDD1 in some instances, but have the flexibility to access files from HDD1 without having to unscrew and swap them out all the time (I have a laptop so I simply can't plug it in and run it as a secondary like I would on a desktop setup).

Hopefully I can come by a definite conclusion of whether it's really not possible with an existing installation of Win7 OS.
m
0
l
Related resources

Best solution

a b G Storage
February 25, 2012 11:00:23 AM

So you have access to your data on both your drives, but not at the same time. Why don't you take a step back, and try to create the "tabula rasa" situation. All you need is a high capacity external drive, which can take all your data, then you can do every kind of dual boot experiments by reformatting/reinstalling your smaller drives, which you are trying to avoid if I understand well.
Share
March 1, 2012 9:45:57 AM

Best answer selected by xskyline_gtr.
m
0
l
July 17, 2012 5:20:16 PM

the same thing is happening to me, but this is happening in my laptop and is the only PC i have, no idea how to solve this problem.
is there a way to initialice the External HD, i dont care at all for the info i have in the external Drive i just want to be able to use it.
m
0
l
!