Solved

No hard disk detected!, then Windows boots

Hello,

Just finished building a pc for the first time. Some pieces I have on it include:
- ASUS P7P55D-E Pro LGA 1156 Intel P55 SATA 6Gb/s USB 3.0 ATX Intel Motherboard
- Intel Core i5-750
- Western Digital Caviar Black WD1001FALS 1TB 7200 RPM SATA 3.0Gb/s 3.5" Internal Hard Drive -Bare Drive

When I boot, I see the motherboard screen, then the screen goes black and appears with the message:

"Warning: No hard disk detected!"

5 seconds go by, then Windows boots perfectly fine.

I can see the drive in Bios and the HD is first in the boot order. The HD and the DVD drive are in sata 1 & 2.

This is baffling myself and my computer literate friends. Any ideas?
23 answers Last reply Best Answer
More about hard disk detected windows boots
  1. You're booting right? I don't see a problem here...
  2. I'm not sure what you mean by booting right (it's booting into Windows eventually). The problem is that every time my computer boots up, it wastes 10 seconds because i see a screen that says "No Hard Drive Detected!", but then ironically boots into Windows.
  3. It sounds like it's looking for an IDE hard drive. I would disable the IDE controller in the BIOS if you don't have any IDE devices.
  4. I don't see anything regarding an IDE controller, what would it usually be under?
  5. Under "Advanced" and "Onboard Devices Configuration" there are options to set the JMicron SATA/PATA Controller and Marvel 9123 SATA Controller to different modes. They should not be set to IDE mode if you don't have any IDE devices.
  6. If there is a hard drive delay setting in you BIOS, set it at 0.
    http://www.images.clunk.org.uk/reviews/ga-ep45-extreme/bios/advbiosfeatures.jpg
  7. Do you have the newest BIOS? I know Gigabyte recently worked on their boot detection stuff.
  8. I'll give a try updating the BIOS. There was no IDE controller in the advanced tab. I also tried setting the hard disk detect to 0 and it doesn't seem to have done anything. Here's a video of the bootup: http://www.youtube.com/watch?v=HjdB5RMpCtg

    Please ignore my roommates talking.
  9. From the advanced tab you go into "Onboard Devices Configuration". That's where you should find the options mentioned above.
  10. shortstuff_mt said:
    Under "Advanced" and "Onboard Devices Configuration" there are options to set the JMicron SATA/PATA Controller and Marvel 9123 SATA Controller to different modes. They should not be set to IDE mode if you don't have any IDE devices.


    Sorry I missed this. I see this in the BIOS. I can either set them both to IDE Mode or Disabled mode. I should set it to disabled?
  11. You should safely be able to disable the JMicron controller. I'm not sure about the other controller. You'll have to check your motherboard owners manual to be sure.
  12. shortstuff_mt said:
    You should safely be able to disable the JMicron controller. I'm not sure about the other controller. You'll have to check your motherboard owners manual to be sure.


    I can disable the JMicron controllers


    The only other mode for the other controller besides IDE and Disabled is AHCI mode.
  13. Start off by disabling the JMicron controller and see if that gets rid of the message at boot time.
  14. I just tried that, it doesn't seem to have changed anything.
  15. Any more information on this question? On my very similar system, disabling the JMicro controller doesn't help. The message seems to be coming from a "Marvell" controller, but that's not shown in the BIOS.

    This is not a huge problem, but it's an annoyance.

    Thanks!
  16. So your BIOS does not have the listings shown two posts up (a Marvell SATA)?
  17. Interestingly, even though I'm using the same motherboard, the BIOS doesn't show the Marvell controller, only the JMicro.
  18. Look for a BIOS update.
  19. Any new information on this? I'm having the same issue.... :??:
  20. I had exactly the same problem, albeit with a P5Q-E motherboard. I changed a couple of settings in BIOS, but what I am pretty sure did the trick was disabling Marvell IDE in Advanced -> Onboard Device Configuration.
  21. an5311 said:
    I had exactly the same problem, albeit with a P5Q-E motherboard. I changed a couple of settings in BIOS, but what I am pretty sure did the trick was disabling Marvell IDE in Advanced -> Onboard Device Configuration.


    Wow this thread is still alive! So after all these years I still haven't found a fix, I've sort of just lived with it.

    an5311, there isn't a a Marvell IDE option. Are you sure you weren't referring to Marvell 9123 SATA Controller?
  22. Best answer
    stotic said:
    Wow this thread is still alive! So after all these years I still haven't found a fix, I've sort of just lived with it.
    an5311, there isn't a a Marvell IDE option. Are you sure you weren't referring to Marvell 9123 SATA Controller?

    I have come across this thread when I was looking for a solution to the same problem as you described. I could not find a definitive answer, so I started going through my BIOS settings and turning off everything that was not necessary. The message that you described disappeared after I disabled Marvell IDE. However, our motherboards, controllers and BIOSs are different.

    I use all my SATA drives in AHCI and have all IDE options (for hard drives) disabled (or set to 0). Are all your drives SATAs? If so, then I think that you should use the AHCI setting as it offers several advantages over IDE, and performance boost is one of them (see e.g., AHCI vs. IDE). However, if your current setting is IDE, then you might have to reinstall Windows after switching to AHCI (see e.g., Can I switch from AHCI to IDE without re-format/re-install?). After you have all your drives working in AHCI, then you should disable all your IDE options (for hard drives).
  23. Oh wow. That actually did it! I had to set the Marvell controller to disabled. Thanks for solving my 5 year old problem!
Ask a new question

Read More

New Build SATA Hard Drives Intel Systems