Sign in with
Sign up | Sign in
Your question
Closed

Memory sizing

Tags:
Last response: in Memory
Share
September 20, 2010 1:55:32 AM

Hi all,

I'm using an Acer laptop which I bought about 3 months ago (the specs are in my sig). Recently I've noticed it's running slower and behaving slightly strangely. I generally checked my Windows environment (disk cleanup, registry cleanup, anti-virus scan, Windows updates, control panel settings, etc.) and noticed in system properties that the amount of usable RAM had decreased from the usual amount.

Basically my installed RAM is 4 gigs and my usable RAM was 3.8 gigs until I did a flash update of the BIOS (about 2 months ago) which then left me with 3.68 gigs of usable RAM. Now though it still says I have 4 gigs installed but only 2.8 gigs usable. So I scheduled a memory test on a restart and just as the test started it quit the test and started up Windows as if nothing had happened, with no error message.

I then thought to try safe mode. Before I scheduled the memory test again I checked system properties and I had my 3.68 gigs back, so it's obviously something to do with my user account. I did the test anyway and it reported there were no errors. Just to make sure I even downloaded memtest86+ (using safe mode with networking) and that also reported no errors.

When using memtest86+ though I looked at the settings for it and noticed there were 2 memory sizing modes: BIOS (standard) and "probe". I tried probe to see if it'd test the full 4 gigs rather than just the usable 3.68 gigs, but instead it tested 2.8 gigs (incredibly slowly) which is exactly what I've been getting in Windows recently. Somehow the memory sizing mode must've changed from standard to probe on a normal startup of Windows.

I'd also noticed lots of memory errors in the performance monitor of Windows since only having 2.8 gigs, so I hope it hasn't led to any data corruption on my HD.

This is a long-winded way of asking how I can change my memory sizing back to standard, why it'd changed and how to prevent it happening again. I did do a search but maybe I didn't use relevant keywords. Any help much appreciated.

Cheers,
Darren (currently in safe mode)

More about : memory sizing

Best solution

a c 347 } Memory
September 20, 2010 2:11:40 AM

Welcome Newcomer! :) 

The RAM is being shared with the integrated ATI HD5650. In addition some memory can be used via BIO H/W reserve an in e.g. Windows XP 32-bit can be know to lose ~ 0.5 GB.

As far as slower, running registry cleaners and similar apps aren't alway a great idea. I understand the reasons, but I too know the ill effects. In addition, as the HDD becomes fuller >75% there's often a degradation is performance. The best thing to do is to uninstall "junk" apps and perform a Defragmentation of the HDD. Also, run MSCONFIG in diagnostic mode and begin adding background apps to check performance draining tasks.

You can always perform a Clean Install and start from scratch; remember less = more speed. Otherwise replace you HDD with a new SSD.

Link - http://www.microsoft.com/atwork/maintenance/speed.aspx

Good Luck!
Share
September 23, 2010 7:58:49 PM

Hi jaquith,

I did put the complete specs in my sig but it only shows the first 4 lines. It's an ATI HD 5470 in my case with 512 megs dedicated and it's not set to share any RAM. My BIOS was using about 200 megs initially and then about 320 megs after a BIOS update (which seems a lot to me), so that doesn't really explain how it was suddenly confiscating 1.2 gigs rather than the usual 0.3 gigs. Also I'm using Windows 7 (64 bit) which apparently is not supposed to do that sort of RAM hogging. My HDD is 20-25% full and I regularly do system related chores to keep it running well.

One thing you did say though which I thought at first didn't apply to this problem either was about registry cleaners. I've been aware for a while that most of them do more harm than good. I was just using the one included in BitDefender Total Security because I thought it was conservative by not deleting useful registry entries. I checked anyway though and each time I'd used it (6 times in all) the only entries deleted were shared DLL associations. Obviously these are important to keep because when I got it to undo all the changes it'd made the usable RAM went back to what it should be.

That's the last time I use any sort of third-party registry cleaner. BitDefender is great but they really should stick to the firewall, anti-virus scanner, etc.

Thanks for the reply as part of what you said turned out to be the answer. This "probe" thing must be just a memtest86+ setting and nothing to do with the OS like I assumed it was before.

Anyway, much respect for the suggestion. Cheers. :) 
Score
0
Related resources
September 23, 2010 8:01:03 PM

Best answer selected by cfoobs.
Score
0
September 23, 2010 10:17:34 PM

This topic has been closed by Mousemonkey
Score
0
!