Sign in with
Sign up | Sign in
Your question

Crucial SSD disappears on x58a-ud7 Marvel

Last response: in Motherboards
Share
September 20, 2010 5:20:37 AM

Great site and forum. Have been reading and learning here for many years. Many thanks to all of the experts out there which contribute! My first time to post something because I am finally stumped despite dozens of hours researching on the web. Here is my setup:

MOBO: Gigabyte x58a-ud7 (rev 2.0)
CPU: Intel Quad Core 3.06 GHZ
RAM: Corsair DDR3 6GB (3 x 2GB)
HDD: Crucial C300 SSD SATA3 64GB (Qty. 2), WD Caviar SATA2 232GB (Qty. 2)
OPTICAL: Lite-on IDE DVD R/W (Qty. 1), Lite-on IDE CD R/W (Qty. 1)
OS: Windows 7 Ultimate 64-bit

What I want:

The best speed possible for the OS to enable quick boot and run time (redundancy not important here). Decent speed for data storage but with full redundancy in case of drive failure.

How I hooked it up:

After much research I put both Crucial SSD drives on the Marvel controller (SATA ports 6 and 7) because both drives and controller support up to 6GB/S. I set the Marvel to IDE mode because I read that the Marvel RAID drivers are lame, at least for now. I installed the OS on the drive in port 6 and left the second drive on port 7 blank so that I could periodically store a full image backup from the OS drive. Both drives are in a removable cage so I can take the backup drive with me for offsite storage when needed.

I also read that the Intel ICH SATA2 controller was the best on the board so I connected the WD Caviar drives to ports 0 and 1 (the blue sockets). Set them up as RAID1 configuration to protect my data.

I disabled the JMicron controller and only left the Gigabyte SATA2 controller in IDE mode (SATA ports 8 and 9 empty) so that it would run the optical drives which are connected to the legacy IDE socket.

The problem:

Everything installed and runs just fine. All drives show up in Device Manager and can be browsed for data. Simple operations such as renaming a file or copying a single file work on all drives. But when I try to copy a large number of files from the spare Crucial SSD drive on port 7 to the WD Caviar RAID1 pair then only a few files make it across before the Crucial SSD drive just disappears from the system. The copy job never completes and the missing drive is just gone, not visible in Device Manager or Explorer. Does not come back when refreshed or rescanned. Then when I reboot it sometimes doesn't show up in the BIOS either, but if I reboot again then it comes back and works fine again until I try another large copy command.

What I tried:
Turned off drive hibernation in power management. Upgraded and downgraded all controller drivers trying various versions (now using latest of everything from Gigabyte website). Upgraded the BIOS to latest FB version. Tried virtually every possible combination of BIOS settings. Swapped and replaced cables, checked all connectors. Removed and reinserted both SSD drives in the hot swap bay. Switched the OS drive to port 7 and backup drive to port 6. Installed numerous utilities including MRU and Intel RST. None of this fixed the problem.

Temporary solution:
Out of desparation I moved the second Crucial SSD drive (the one I plan to use for OS backups) to port 2 on the ICH controller and it works like a charm. I can now perform large copy and transfer commands to/from the SSD drive without it disappearing, and the OS still runs fast on port 6 of the Marvel. But this SSD drive is a SATA3 6GB/S drive and if I keep it on the SATA2 controller (as non-RAID) then I assume it will be at least a little slower.

My questions:
Why won't both Crucial SSD drives work on the Marvel controller at the same time? Wouldn't they both be much faster on the Marvel than on the Intel, assuming I keep them in non-RAID configuration? I understand that if I wanted to use them as a pair in RAID0 then they would do just a little better on the Intel controller, at least for now until Marvel improves their RAID drivers. But I am not using them in RAID and just want the fastest possible performance from them which I assume is on the Marvel since it is the only one which supports up to 6GB/S (albeit limited by the PCI-E routing).

Any advice or help from the pros?
September 20, 2010 3:20:36 PM

Thanks for the note. That is a good post and I have already read most of that info elsewhere. But it does not directly answer my questions above.

Most people which post benchmarks bashing the Marvel SATA3 controller are critical of it primarily because it has less efficient, immature RAID drivers and because the 6GB/S speed will be limited by the PCI-E pipeline. I understand this, yet when using SSD drives rated for 6GB/S in non-RAID configuration then it should still be at least a little faster, something which a few benchmarks have already confirmed. I guess it depends on whose testing you believe, and what hardware they tested with, but even if the Marvel controller is the same exact speed as the Intel ICH (or even slightly slower) then both drives should still work when connected to either controller.

I am not arguing speed as I can and do plan to test that for myself once I get both drives running on the Marvel. It just doesn't make sense for one SSD to periodically disappear from the Marvel but work fine on the ICH. Maybe a driver issue? The only similar report I found was for very large (1TB) drives on Windows 7 to disappear after sleep mode but this was resolved with turning off drive hybernation and applying a 6-month old Windows hotfix which should already be part of the latest updates. I can't find any reports of this happening on the x58a-ud7 which is why I am hopeful that maybe it is just a driver or obscure setting somewhere.

Also, I expect the Marvel performance will improve when updated drivers are released down the road, and the Intel ICH may not be so fast when copying or moving large data sets between multiple SSD and platter drives on the same controller. Does anyone have more data to share along these lines?
m
0
l
!