Sign in with
Sign up | Sign in
Your question

XFX ATI HD 4870 Crash on Every game ......

Last response: in Graphics & Displays
Share
February 3, 2010 7:09:47 PM

I have a XFX ATI RADEON HD 4870 1GB.
it Stop displaying on every game i played after 5 or 10 or sometime after 20 min. i Thought my PSU is old enough to provide good power to card and motherboard, so i bought a NEW Corsair TX750 and still the same result. So what do i do now.Some i got VPU recovery error and then it display again and again goes to black screen and sometimes my monitor displays vertical and horizontal frequency Error. i check this with another display and still the same result.......Now m in a Deep trouble......Help me Help me in this regard....and tell me if my ATI HD 4870 is faulty so that i can claim warranty...or some other issue.

my Specc are..

motherboard:intel DP35DpM
processor: intel E8400 @ 3ghz
PSU : Corsair TX750
RAM: 2 GB @ 2 stick Corsair Twin2x 800Mhz
1DVD Rom
1 IDE HDD @ 80Gb
1 SATA @ 250 GB
1 SATA @ 500GB
Graphic CARD: XFX ATI HD 4870 1GB
February 4, 2010 2:54:35 AM

Sounds like its your graphics card. Did you just recently buy it or did it just suddenly start doing this one day?
m
0
l
February 4, 2010 3:19:51 AM

It will be best if you test your card on some other system....Most probably your graphics card is faulty but it may also be the fault of your mobo ....Is your card properly seated on the mobo???What temps are you running at??Are your drivers updated??
m
0
l
Related resources
February 4, 2010 4:35:50 AM

it seems like overheat problem to me since the problem only appear after a few minutes playing the game and not come right away when launching the game. check you idle and in game temperature. but this problem may also caused by card going bad.
m
0
l
February 4, 2010 4:45:23 AM

paperfox said:
Sounds like its your graphics card. Did you just recently buy it or did it just suddenly start doing this one day?


Actually its doing from the day i purchased. but i thought my PSU is insufficent
(old :p SU cooler MAster Extreme power 550watts with 2 +12volt with each @16A) so i bought a new after 3 months(New PSU: Corsair TX750) but again i have the same problem.
m
0
l
February 4, 2010 4:50:17 AM

Did you have a card before that XFX 4870? If it was an Nvidia then maybe you dident completely remove all of its drivers and its causing conflicts.
m
0
l
February 4, 2010 5:03:53 AM

paperfox said:
Did you have a card before that XFX 4870? If it was an Nvidia then maybe you dident completely remove all of its drivers and its causing conflicts.


yup the old one was Nvidia but i formate the OLD OS and instal a fresh OS before that and the problem is still there......:( 
m
0
l
February 4, 2010 5:09:51 AM

renz496 said:
it seems like overheat problem to me since the problem only appear after a few minutes playing the game and not come right away when launching the game. check you idle and in game temperature. but this problem may also caused by card going bad.



humm...my idle temp of HD 4870 is 60C or 62C and in game it reaches to 75c
and to view that i intall another my brother LCD with this card to play game on 1 LCD and view temp onanother LCD and i saw before crash it reaches to 75c . and i also open the case for proper ventilation just to check heat issue but still no progress and also i manually increase my FAN to 80% then 100% but the problem is still the same......so what do i do ,can i claim warranty for that as my card is faulty........:( 
m
0
l
February 4, 2010 5:11:36 AM

so driver conflict is not the problem and your temps are perfectly normal too....I feel you should return it to your manufacturer..
m
0
l
February 4, 2010 7:31:44 AM

I also got help from the support of the XFX and they are telling me to check this card on another system.
will try later when get back home.
m
0
l
!