Sign in with
Sign up | Sign in
Your question

Radeon 5450 on Lanparty NF4 boards

Last response: in Motherboards
Share
September 20, 2010 6:17:04 PM

Hello, I have a NF4 based lanparty board paired with a 165 Opty. I want to add one of the new 5000series ATI video cards but hear they won't work with NF4 chipset boards unless the MF has updated the bios - does anyone know if 5000 series video cards work with the NF4 lanparty boards?
a c 169 U Graphics card
a c 136 V Motherboard
September 21, 2010 1:53:37 PM

Hello and welcome to the forums
Well PCI-E 2.0 is backward compatible with PCI-E 1.0, so it should work fine, however make sure you have an adequate PSU(Also update your BIOS to the latest version,it won't do any harm)
m
0
l
September 21, 2010 2:35:37 PM

I know that it should work - but I've read two different threads where someone mentioned that they couldn't get it to work in two different NF4 boards. Then I read a thread on AVSFORUM by someone who said they were getting one and would find out if it worked on their NF4 board - but they've not followed-up.

It seems it's a board-to-board thing and was hoping someone on this DFI forum have tried to use a 5000series card on an NF4 board and share their experience.

I plan to use the latest BIOS, I just don't want to order and have to pay return shipping if it doesn't work.
m
0
l
Related resources
September 22, 2010 2:24:19 PM

Well, for anyone curious - I did end up getting a 512mb 5450 (visiontek) and it works fine on my NF4 based board - no issues at all.
m
0
l
a c 169 U Graphics card
a c 136 V Motherboard
September 22, 2010 3:56:58 PM

Glad to hear it.
Really,there wasn't any logical reason for the VGA not to work on your board.(Because a PCI-E 2.0 card should work fine in a PCI-E 1.0 slot)
m
0
l
!