Sign in with
Sign up | Sign in
Your question
Solved

I5 650 thread

Tags:
  • CPUs
  • Core
  • Intel i5
Last response: in CPUs
Share
April 19, 2010 9:29:38 PM

Hello,

Is it possible to have the i5 650 work with one thread to a core (a total of two threads) instead of working with two threads to a core (total of four threads)?

Thanks

More about : 650 thread

a b à CPUs
April 19, 2010 9:43:45 PM

You should be able to disable hyperthreading (SMT) in the bios.
m
0
l

Best solution

a b à CPUs
April 19, 2010 9:44:16 PM

Yes, this feature is called Hyperthreading and it can be disabled in the bios.
Share
Related resources
a c 77 à CPUs
April 19, 2010 9:56:56 PM

Yes, you can disable Hyperthreading in the BIOS, but why would you? Hyperthreading makes the CPU perform better. Is there a reason you're wanting to do this?

Edit: If you're doing this because you have a single threaded app, don't bother. It won't make it run any faster. If it can max out one physical core then disabling Hyperthreading will not make it run faster. In fact, it will hurt performance because the system will have less options on where to assign background tasks.
m
0
l
a b à CPUs
April 19, 2010 10:02:34 PM

Maybe he wants to benchmark stuff with HT on and off. Not everything works better with HT btw, although most things do there are a few things that HT can make worse.
m
0
l
April 19, 2010 10:09:00 PM

It changed in the BIOS the line:
Intel (R) HT Technology and put it in Disable
Now I have only two threads running.

The reason for it is that now the program is using instead of 25% of the CPU usage it uses now 50% of it, I checked and verified it.

In effect the program now does the calcualtions much faster then before.

It is correct that if I use multiple programs then it is better to have four threads, but in my case my main objective is to have this program run as fast as possible.

Thanks for everyone's support
m
0
l
April 19, 2010 10:21:59 PM

No that program isn't running any faster now, it's just that now windows sees your processor as a dual core instead of a quad core. One core running at %100 out of two is %50 of your total processor power but if you use hyperthreading it still runs %100 of that same core but now you have 3 threads idling thus windows sees it as %25 of your total processing power.

To put it even simpler turn hyperthreading back on. It will help you, trust me
m
0
l
a c 77 à CPUs
April 19, 2010 10:22:55 PM

You could also go into Task Manager and assign the affinity to only use the first core (CPU 0). You just right-click on the task in Task Manager, select "Set Affinity" and un-check all but CPU 0. That way your task would only use the first core and you wouldn't have to cripple your CPU in the BIOS.

Edit: Paigeinfull is right if the task was already maxing out the first core. I bet if you time whatever task you're performing with Hyperthreading enabled and again with it disabled you will see that it's slightly slower with it disabled.
m
0
l
April 22, 2010 7:24:37 PM

Best answer selected by gideonm.
m
0
l
!