Sign in with
Sign up | Sign in
Your question

Chkdsk is corrupting files

Last response: in Windows XP
Share
September 29, 2012 8:27:42 PM

This is a weird one. I have a Lenovo T400, WinXP SP3. Bought a Crucial 256G solid state drive to replace my 250G HDD. Cloned the drive with Apricorn EZGig and a SATA cable. Computer booted up normally, but on reboot went into CHKDSK with no option to quit. While running, CHKDSK gave me several messages re deleting corrupt attribute list entries and records. Then the computer then stuck on boot, with the message: WINDOWS\SYSTEM32\CONFIG\SYSTEM file corrupt.

In fact, it showed 0 bytes, and was corrupt to the point that it could be neither changed or deleted, no matter what methods I tried from online discussions.

Replaced the original drive, got my computer back, formatted the SSD and got exactly the same result. Crucial support was unable to solve it, and I shipped the drive back.

This is the really weird part. I then ordered a Seagate Momentus XT hybrid 500G drive, with another copy of EZGig and another Apricorn SATA cable. I am getting exactly the same result. I have reformatted the new drive, same thing. I got it to the point where at least I have the option of cancelling CHKDSK on the reboot, but if I let CHKDSK run, I get exactly the same result, with exactly the same file numbers, attribute record numbers, etc. I have a snapshot and could publish it, but I won't unless someone thinks it's relevant.

One more thing. The new drive has a dirty bit, and I cannot reset it. CHKDSK obviously won't reset it. It will corrupt the WINDOWS\SYSTEM32\CONFIG\SYSTEM file instead. If I don't run CHKDSK everything works. My original drive, which I have re-installed several times to get my computer back, has no dirty bit.

I have seen nothing like this on any online forum. If there's anyone out there with an out-of-the-box idea, I would really appreciate it. I think I've tried just about everything.
October 1, 2012 10:26:21 PM

Try running a full disk check on your C drive before you clone.
October 3, 2012 7:29:30 PM

PhilFrisbie said:
Try running a full disk check on your C drive before you clone.


Thanks for the suggestion. Tried it, no change. I'm going to look for another cloning program. I have a registered version of Acronis True Image, but it's about 5 years old and is having its own issues.
Related resources
October 3, 2012 11:03:49 PM

As a temporary work around you could try sysinternals autoruns and disable chkdsk, but this should not be happening.
!