Fix broken shortcut on external hard drive

I have files on an external hard drive that I can't access. When I do a search, they come up in the search. But when I click on them to open, I'm told that the shortcuts to those file are broken.

They are simple Word Documents, nothing fancy. They don't show up in the directory window, just in the search window. But I can't open them.

Help!

Marie
5 answers Last reply
More about broken shortcut external hard drive
  1. This also sounds like a permission issue, you need to take ownership of the files as described here: http://technet.microsoft.com/en-us/library/cc753659.aspx
  2. Thank you so much for your prompt reply. I tried to do as you instructed.

    However, when I click on the "security" tab, a window pops up, saying that the name of the target file is incorrect. (I found these files in Recent Places.)

    The boxes in "Advanced" are grayed out so that I can't click on anything.

    Help!
  3. Everything in recent places is just a shortcut, you would have to go to the actual files take ownership as described in that link. Can't do it to a shortcut.
  4. I tried to access the files using both search and recent places. After clicking on properties, I tried to click on the security tab. But a window popped up, saying the file name was invalid.

    How can I get to the files directly in order to take ownership when they don't show up on the external hard drive directory?

    Thanks for your help.
  5. Can you access the drive in disk management, if so does it have a drive letter or can you assign it one?
Ask a new question

Read More

Hard Drives External Hard Drive Storage