Sign in with
Sign up | Sign in
Your question

PCI Device in Device Manager Assistance with Drivers

Last response: in Windows XP
Share
October 1, 2012 5:54:51 PM

Sup Everyone,

My son has a Dell Dimension 4600 desktop computer. Each time he turns on his computer he gets the "Found new Hardware" prompt. However, he isnt sure why its popping up or know which drivers to look for.

According to the PCI Device Properties the details tab indicate the device id as,

PCI\VE_10DE&DEV_0BE3&SUBSYS_00000000&REV_A1\5&28662550&0&0110F0

According to www.pcidatabase.com we get the following results;

0x0BE3 Chip Number: NV34
Chip Description: Riva 128
Notes: Driver for Windows XP

However, we have been unlucky finding drivers for this device. Can anyone offer any assistance?

Thanks in advance
October 1, 2012 6:06:00 PM

I forgot to add, according to wiki, Riva 128 is an old video card Released in late 1997 by Nvidia, the RIVA 128, or "NV3", was one of the first consumer graphics processing units.

My sons current video card is a PNY Verto NVIDIA GeForce 8400GS 512MB.

m
0
l
Related resources
October 1, 2012 6:56:16 PM

The Nvidia drivers for My sons current video card, PNY Verto NVIDIA GeForce 8400GS 512MB are already up to date. This is where the issue lies.
m
0
l
October 2, 2012 10:54:05 AM

ex_bubblehead said:
Download and run Driver Sweeper: http://www.guru3d.com/content_page/guru3d_driver_sweepe...

Then reinstall the NVidia drivers.

I tried to dowload it from two differet sites but keep gettig the followig error, "The applicato failed to iitialize properly." Is there another app that does the same thing?

SR-71 Blackbird said:
http://www.dell.com/support/drivers/us/en/19/DriversHom...

Search here for the missing driver ^

I tried and ended up messing up my display. I'm trying to restore to an earlier date to fix that. I don't want to guess around installing drivers without being sure what it is I'm installing.
m
0
l
!