Sign in with
Sign up | Sign in
Your question

Radeon HD 4670 No sound device

Last response: in Graphics & Displays
Share
February 5, 2010 10:34:59 AM

Hello,

Hopefully someone can help?

I have just installed a Sapphire Radeon HD 4670 1GB DDR3

I cannot find the ATI HDMI Audio device (or anything similar) in device manager, I have no exclamations/crosses for un-recognised hardware etc.

I have tried disabling my onboard (soundmax) hd audio controller, both in BIOS and device manager.

I have tried installing the latest catalyst 10.1 (and beta 10.2) drivers

I have tried to install the Realteck ATI driver, but it says there is no device detected so will not install

I am using Windows 7 (RC) on an Asus P5LD2 SE motherboard, 4GB DDR2 memory, Intel Dual Core CPU.

I have searched far and wide, but have not found success :fou:  . I do not have another system to check the graphics card.

Does anyone have any ideas which may help?

Thanks in advance
February 13, 2010 8:15:11 PM

solved by re-installing windows 7. device now shows in device manager
!