Sign in with
Sign up | Sign in
Your question

sapphire card question

Tags:
  • Graphics Cards
  • Sapphire
  • Graphics
Last response: in Graphics & Displays
Share
February 6, 2010 2:16:55 AM

Hey another thing i wanted to ask about the sapphire 5770 vapor-x card I have a thermaltake 850 watt power supply and the max amp output on the 12 v rails is 30 amps.
I am not sure what is needed to power this card.
I am using the 6 pin pci e connector that is rated at 30 amps.
The thing is when I start to boot the computer I dont hear the beep that i normally do and I have no signal going to my lcd monitor through my dvi ports.
Everything lights up and the card appears to power up the fan spins and the lights come on.
If I switch back to my old 8800 ultra everything powers up and runs like a champ, so I was thinking that the new card was bad.
Any input would be appreciated thanks

More about : sapphire card question

February 6, 2010 5:16:02 AM

maybe you've got a death on arrival card just rma it don't worries..
m
0
l
a c 190 U Graphics card
February 6, 2010 12:55:14 PM

If u have another computer then u can try it there...
If it still not working then u can rma the card and get a replacement... :) 
m
0
l
February 6, 2010 8:38:39 PM

shagrathdex666 said:
maybe you've got a death on arrival card just rma it don't worries..

thanks for your imput I am going to rma the card and see if a new card will do the trick.
Thanks again :wahoo: 
m
0
l
February 6, 2010 8:40:55 PM

wa1 said:
If u have another computer then u can try it there...
If it still not working then u can rma the card and get a replacement... :) 

I dont have another computer set up but a buddy of mine will let me check it on his thank you for the reply
m
0
l
February 18, 2010 11:09:06 PM

I think I know what is happing with my 5770.
I have an older A8R32-MVP DELUXE motherboard what I believe is that the motherboard is not recognizing the new 5770 video card.
At that time about 4 years ago a one gig of memory on a video card was not thought of yet, well not for the every day joe.
So I thought all I need to do is update my bios and chipset drivers so I did that .
The bad thing is that the last update for my morther board was in 2007.
So I think I am a victim of old hardware blues =(
I think my only corse of action is to update my motherboard.
What do you all think ? any imput would be appreciated.
m
0
l
!