Sign in with
Sign up | Sign in
Your question

Upgraded Corsair HX 620 to HX750 and PC won't start

Tags:
  • Power Supplies
  • Corsair
  • Components
Last response: in Components
Share
April 24, 2010 12:08:21 AM

I'm building a new system and have been tweaking it using a 3 year old Corsair HX 620. My new HX 750 arrived today. I tested it using the paper clip start and checked the voltages. They seemd pretty good but the gray wire was only about 4.6 but I figured that was within spec.

I am using a Gigabyte GA-X58-UD3R. When the 750 is in standby mode the board's blue "cmos reset" switch on back does light up. However, once I press the power button the computer does nothing other than light up two leds on the board which are either for Northbridge or DDR phase according to the manual.

Any ideas? I made sure I only used the new modular cables with the new psu (Corsair's site said to make sure of that).

More about : upgraded corsair 620 hx750 start

a b ) Power supply
April 24, 2010 12:36:21 AM

does it work if you pwoer it off of the old hx620?
m
0
l
April 24, 2010 12:48:57 AM

Yes, I just tried again with the old HX620 and it was fine. I loaded the fail safe bios settings. I then tried with the new HX750 and still nothing. I'm going to check the gray wire to see if it's not sending enough voltage at startup.
m
0
l
Related resources
April 24, 2010 1:17:52 AM

Well, checked again and on my old psu the gray wire is exactly 5.00

However, the gray wire on the new 750 watt psu is only 4.62, so that is beyond 5% I assume maybe that is the issue.
m
0
l
April 24, 2010 1:22:17 AM

Are you sure you have everything hooked up correctly? I once had to show this person who claimed to be a PC tech the correct way to install a PSU.
m
0
l
April 24, 2010 1:28:00 AM

Yes, everything was correct. It gives the board some power as led lights are lit but it does nothing when you hit the power button. It doesn't even struggle to start, simply nothing happens, no fans spin, etc once it's in the computer
m
0
l
a b ) Power supply
April 24, 2010 1:32:33 AM

did ur power button header wuere it connects to the mobo fall out?
m
0
l
April 24, 2010 1:41:08 AM

shovenose said:
did ur power button header wuere it connects to the mobo fall out?



Nope checked that first. I guess I'll just use the old one until they can get me a new one...I've only ever bought four Corsair products and now 2 have been doa...so frustrating.
m
0
l
a b ) Power supply
May 7, 2010 6:52:30 PM

Have you tried clearing the CMOS?
m
0
l
a b ) Power supply
May 8, 2010 3:39:56 AM

i just learned that to clear the bios on my new mobo (cheaps ecs/elitegroup mobo) one presses the pageup key while pressing power button. quite epic really!
m
0
l
May 10, 2010 1:17:24 AM

Yes, I had tried clearing the cmos. Corsair took FOREVER to send me an RMA number but they finally gave me one.
m
0
l
!