Solved

New CPU, won't boot

Hope this is the right forum for my problem.

I've had a 1.8ghz core2duo for a few years now (think it's E4300 or something). I built this system a few years ago replacing parts here and there. Recently I ordered a 2.93ghz core2duo (E7500) from newegg and received it today.

Anyway, I opened my computer, removed the heatsink and cpu, inserted the new cpu, cleaned the heatsink and added new arctic silver 5, replaced it, and turned on the computer. It seemed to start up as the fans were all running, but nothing came up on the monitor, and my keyboard didn't light up. I let it run for 30s or so and reset, still nothing happened.

At this point I thought I broke my mobo so I replaced my old cpu. It booted up fine. I restarted into bios and chose failsafe default settings, restarted and it was still fine. Opened it up and reinstalled the new cpu, tried again, nothing.

Next I removed the mobo battery for 30s and replaced it. Started comp, still nothing. Put in my old cpu again and now i'm here on the forums looking for help.

So does this cpu seem to be dead, or are there other troubleshooting steps I can take? I want to make sure I've tried everything before RMAing it or whatever.
7 answers Last reply Best Answer
More about boot
  1. What motherboard do you have? The most likely cause of your problems is that your motherboard doesn't support the E7500 with its current BIOS version. You will need to at least update the BIOS to the latest version if the motherboard supports it at all.
  2. Best answer
    You may be out of luck depending on which revision of that motherboard you have. The revision will be printed on the lower-left corner of the motherboard. There were three revisions of that board, 1.3, 2.0, & 3.3. The only revision that supports the E7500 is 3.3, and it needs the latest F14 BIOS.

    http://www.gigabyte.us/Support/Motherboard/CPUSupport_Model.aspx?ProductID=2456

    http://www.gigabyte.us/Support/Motherboard/CPUSupport_Model.aspx?ProductID=2424

    http://www.gigabyte.us/Support/Motherboard/CPUSupport_Model.aspx?ProductID=2510
  3. I have rev 3.3. CPU-Z says my BIOS is version F10. I'll grab F14 and see how it goes.

    Will report back in a bit either way :D Much thanks for the help so far.
  4. Updating the BIOS to F14 should do the trick, even though the 965 chipset doesn't "officially" support the 45mn chips.
  5. Worked! Thanks for all the help :D
  6. Best answer selected by urnotmega.
Ask a new question

Read More

Homebuilt CPUs Systems Product