Sign in with
Sign up | Sign in
Your question

GTX 275 & Empire total war

Last response: in Graphics & Displays
Share
February 9, 2010 3:48:42 AM

Hey all,

I recently bought Empire total war off steam and when I got it all fired up and working i was a little disappointed with the graphics. I have a EVGA gtx 275, and during the various cut scenes, the graphics seem very blurry in some places and when zoomed out, soldiers look almost toy like in their movements and looks. Also when i'm playing on the campaign map everything looks kind of cartoonish although that could be the way the game just is. But the thing that annoys me the most is during the battles. The trees look fuzzy and some trees have slight artifacting, and the battlefield scenery graphics in general looks somewhat lackluster when I zoom in on the map. Shadows seem to flicker when i move around the map. And it seems to play slightly sluggish at times but that could be due to the high graphics settings. Even when I have the graphics up all the way the graphics don't seem to improve much if not. I thought this may be something with my video card but im not sure. I heard its just a problem with the compatibility between Empire total war and nvidia. I have all the graphics on either high or ultra and it seems to make no difference. And I just installed the latest drivers (196.21) from nvidia's website and im running at my native resolution of 1920x1080. Does anyone else have this problem and if so is there a solution because I looked around the internet for a bit and could not really come up with anything. I posted my system specs below, Any help is appreciated. Thanks in advance.

CPU: i7 920 @ 2.66ghz
RAM: 6gb OCZ Gold 1600mhz
Mobo: Asus P6T deluxe v2
Video card: EVGA GTX 275
OS: Windows 7 64bit
PSU: Corsair 850tx
HDD: 1TB Western Digital Caviar Black
February 13, 2010 8:54:36 PM

I have an almost identical CPU (Q9650) and a GTX295 and am in a very similar situation as you. Empire simply is an unoptimized game, I fear. Not as smooth as Medieval II. Try playing around with the graphics settings a bit and see what suits you best.

You'll gain massive performance by lowering the shadows and setting the AA from 8x or 4x to 2x, which should actually be enough.

And I don't notice any improvement with SSAO enabled, so I'd disable it.
m
0
l
!