Problem Overclocking I5-3570K

Hey there. I have a i5 3570K and a ASUS P8Z77-V LX motherboard and I am really struggling to get it to overclock.

In the EZ BIOS, the CPU will mildly bump from 3.4 to 3.5GHz under performance mode but I cannot get it to shift from 3.4 in advanced mode.

I have noticed the board says the max multiplier is 34 and the default for this cpu is 34 but I thought the K CPUs are supposed to be unlocked?

I have updated the BIOS but whats confusing is I have read other people successfully overclocking with this board.

Do I need to bump the BLCK frequency up?

Apprciate any help.. just come from a FSB Core 2 Duo setup so its all a little alien to me.

Cheers
12 answers Last reply
More about problem overclocking 3570k
  1. I'm just like you to see if someone would help ....
  2. I don't have your board, but I can answer 1 of your questions. You don't want to change the BLCK, only the multiplier.
  3. thanks for that post but it doesnt really answer my question. im pretty sure the problem is the multiplier refusing to go about 34. also the chipset is z77.
  4. heres a screenshot of what i mean. its a K processor so i should be able to surpass 34 but it says its the maximum. any ideas anyone? im on the latest bios =/

    screenshot:

    http://img401.imageshack.us/img401/7869/121130001939.png
  5. have you tried in bios

    AI Tweaker -> CPU Power Management -> "CPU Ratio

    or

    AI overclock tuner - manual
    Turbo ratio - by all cores
    By all cores (can adjust in OS) - 40 (40 is as an example)

    bit late here so cant quite remember the exact bios settings without rebooting to have a look

    or try AI suite in windows just to see if the multiplier rises

    i wouldnt recommend AI suite for overclocking normally as it tends to over volt --but just as a test to see if your multiplier will go up it will be ok
  6. have tried the cpu ratio it doesnt go up. and the turbo ratio by all cores isnt a selection.. i have seen this on other boards but mine doesnt have it.. so frustrating. :(
  7. have also tried ai suite.. it said i was running at 4.3ghz but cpu-z said otherwise.
  8. i have an asus P8Z68-V PRO/GEN3

    and must admit the bios set out isnt great in my opinion

    sometimes not easy to work with

    have you tried the auto overclock in the bios?

    again i wouldnt normally use that but do it manually

    but just to see if it will raise your multiplier
  9. xenontek said:
    have also tried ai suite.. it said i was running at 4.3ghz but cpu-z said otherwise.


    what speed did cpuz say?

    and did you actually have the cpu under load?

    as if it was idle cpuz would show 1600mhz or similar
  10. ok have sorted it. reset everything and tried again. it doesnt show on the bios as being overclocked etc but now on prime95 the temps are high and its showing at 4ghz in cpu-z. is 84oC a little steep? i am using the stock cooler for the time being =/
  11. 84c is too high--probably even for the stock cooler on prime95

    check the cpu voltage under load in cpuz just by doing stuff you would normally do

    check the temperatures under normal use under load

    i wouldnt really run prime95 with a stock cooler
Ask a new question

Read More

CPUs Overclocking Intel i5