Disk Boot Failure when storage drive connected

I have two SATA hard drives connected to a SATA PCI card on Windows XP. The boot drive is a WD Black and the storage drive is a Maxtor. I've been getting BSOD's periodically (Invalid process detach attempt) and couldn't figure out what was causing them but everytime it happened I just restarted and everything was ok again.

Well this last time the BSOD happened I shut down the pc instead of restarting and decided to switch the RAM in different slots just to see if that would help. I also plugged in the SATA cables into different SATA ports (the SATA card has 4 ports). Then I restarted and that's when I got the Disk Boot Failure Insert System Disk and Press Enter message. I put the RAM sticks and cables back to their original place but I still get the error.

After isolating the drives I found out it was the storage drive causing the error message. If I try to boot the pc with both drives attached I get the error. If I boot with only the storage drive attached I get the error. If I boot with only the boot drive it loads into Windows with no problem. So there seems to be something wrong with the storage drive. I don't think the drive is failing since I haven't heard any sounds coming from it that a dying hard drive typically makes.

Then I (stupidly?) decided to boot with only the boot drive attached, then after it was recognized during bootup I immediately plugged in the SATA cable to the storage drive. When I got into Windows I opened My Computer and saw the storage drive there but it was empty. Actually I didn't even try to double click on the drive, I right clicked and clicked Properties and saw it was empty.

Anyone know what's wrong? Why do I get Disk Boot Failure when both drives are attached but the boot drive is fine? It's like my pc thinks the storage drive is supposed to be the boot drive. Does it have anything to do with the MBR being damaged or does that only apply to the boot drive? How can I save the drive please help!

p.s. I forgot to mention I the storage drive has been encrypted with True Crypt. When I tried to mount the storage drive in True Crypt it said, "Error: Cannot mount volume. The host file/device is already in use. Attempt to mount without exclusive access failed as well.
9 answers Last reply
More about disk boot failure storage drive connected
  1. anybody have a clue?
  2. Some times drive fail without giving any indication first, reading your post and what you have done it has failed either mechanically or corrupt data system.
  3. If it's a corrupt data system does that mean the drive can be saved? What software can I use to try and recover the data?
  4. Corrupt data system and you should be able to reformat the drive. I do not have any experience with data recovery so I can not recommend a program but posts here are full of people recommending programs. The only thing I know that works is professional data recovery service which is expensive.
  5. Ok thanks for the help. God this is so frustrating. I just lost another hard drive like a month ago. And that one was a Maxtor also. The worst drives I've ever used!
  6. Maxtor is now owned by Seagate so utilities to check the drives are available from their website.
    I have several 7 to 10 year old Maxtors still running in different machines and have not lost one yet.
  7. I put in a Seagate tools floppy disk when I rebooted and when I got the Disk Boot Failure message I pressed Enter but nothing happened. How am I supposed to check the drive if I can't access it?

    I gotta go to bed I'll check on this tomorrow. Thx.
  8. You know what, I think my motherboard might be going bad. The onboard sound doesn't work anymore and neither do the USB headers. I think it's time to buy a new computer. Hopefully my drives will come back to life once I plug them into a new motherboard.
  9. Hi, I don´t know if your problem is solved by now. Hope it is.

    In any case, I had a similar situation, but it was with the only (hence system) drive, it occurred in two PCs. I think it might have been caused by a hard drive test that I ran from DOS using a bootable CD.

    What I did was install the drive in another PC - in your case this wont be necessary, you already have another drive with the system.

    Then, used Mini Tool Partition Wizard (there is also Easeus Partition Master, I am sure there are also more programs like them). It saw the drive, but reported it empty. (The same thing happened with XP's Disk Management: Start/Right Click on Computer/Mange/Disk Management ).

    Highlighted the drive, and then chose Partition in the top menu, then Partition Recovery, and the short/fast search for the partitions. They (there were 2) promptly showed up. You are asked if you want to recover them, you do! In my case, both of them.

    You need to make sure that the Type (Primary or Logical) and Status (in case of a system partition) are the correct ones. My partitions were both Primary, which I changed through Partition in the top menu, followed by Modify..., since they both had been recovered as Logical. One was a system partition, so its Status had to be changed to Active.

    Very important, after you complete the above operations, go to Disk, in the top menu, and then click on Rebuild MBR (Master boot record) - this is probably what got messed up in the first place, and led to losing the partitions.

    Once this was done, the hard drive worked fine again.

    Also, I am not sure how advisable it is to plug in a hard drive while the PC is running - this might be what caused your problem.
Ask a new question

Read More

Hard Drives SATA Storage