Solved

5850 freezing

I built a new rig a month or two ago and have been having issues with video. I first noticed the problem when I would try and watch Hulu or movies in full screen. Every now and then it would freeze and the screen would go black while still playing audio for a minute then everything would stutter and stop. This then started happening while loading Battlefield 2. It would make it through the EA intro and then the video would stutter on the next part of the opening before it froze and the screen went blank. I have tried updating the drivers on my card but so far nothing has helped.

My system is an i5 750 on a Gigabyte UD3r board with Win7 64 bit.
7 answers Last reply Best Answer
More about 5850 freezing
  1. I have the same problem except mine onli happens when i am not playing games.

    I have a i5 750 on a MSI P55 CD53 with a radeon 5850. Using win 7 64bit.
  2. racermx187 said:
    I built a new rig a month or two ago and have been having issues with video. I first noticed the problem when I would try and watch Hulu or movies in full screen. Every now and then it would freeze and the screen would go black while still playing audio for a minute then everything would stutter and stop. This then started happening while loading Battlefield 2. It would make it through the EA intro and then the video would stutter on the next part of the opening before it froze and the screen went blank. I have tried updating the drivers on my card but so far nothing has helped.

    My system is an i5 750 on a Gigabyte UD3r board with Win7 64 bit.


    ATI Catalyst had released a new Catalyst 10.2 api driver for their new Radeon HD 5K series to fix the grey screen of death and etc... Try downloading the 64 bit version for Windows 7 from ATI's driver download website and see if the problem is solve.
  3. Techno-boy said:
    ATI Catalyst had released a new Catalyst 10.2 api driver for their new Radeon HD 5K series to fix the grey screen of death and etc... Try downloading the 64 bit version for Windows 7 from ATI's driver download website and see if the problem is solve.



    I have updated the drivers and everything since the hot fix came out and it never fixed my issues
  4. Best answer
    racermx187 said:
    I have updated the drivers and everything since the hot fix came out and it never fixed my issues


    1. This problem could also have been due to Gigabyte's Bios since you are using Gigabyte motherboard. Try updating Gigabyte's Bios to the latest version. Mouse cursor problem with Radeon HD 5K is also associated with Gigabyte's Bios especially the Bios of Gigabyte P55 series.

    2. If updating Gigabyte's Bios does not help then maybe the problem could be caused by your PSU. Check to make sure that your PSU is adequate. Some people solved this problem by buying a newer, better quality, more powerful PSU.

    3. Update your Monitor's display driver to the latest version.

    4. Or.... Take your video card to the supplier and test your video card in their system. If it works then it means that you could have problem with your PSU or Monitor's driver or due to applications that you were using or Windows 7 OS issues.

    5. If your video card does not work in the supplier's computer or other computers, then this means that you could have a defected video card and you had to RMA it.

    So...... Try these steps and Good Luck. :)
  5. This thread might also help you a bit:

    Thread: Sapphire HD-5850 problem (+ recorded video of it):

    http://www.vgaforum.com/archive/index.php/t-21904.html

    The OP who made that thread on the vga forum was also having similar problem and his system spec is similar to your system spec too so check that out.
  6. Techno-boy said:
    This thread might also help you a bit:

    Sapphire HD-5850 problem (+ recorded video of it):

    http://www.vgaforum.com/archive/index.php/t-21904.html

    The OP who made that thread on the vga forum was also having similar problem and his system spec is similar to your system spec too so check that out.



    Thanks for the link. My problem is a little different as the screen goes black fir a while then will come back for 30 seconds then go black again. Also, if I get into a game it never happens. Only when first loading the intro or when I first blow a movie up to full screen. I will try flashing to a new BIOS as I heard from someone having similar problems on the UD4 board did this and it solved his issues.
  7. Best answer selected by racermx187.
Ask a new question

Read More

Radeon Video Graphics