Sign in with
Sign up | Sign in
Your question

Iomega 1tb External Drive Not Picked Up

Last response: in Storage
Share
February 27, 2012 6:18:34 AM

Hi

I have a 1tb Iomega external drive that windows will no longer acknowledge as of yesterday. Its been working fine for the past 1 1/2 years and has not been dropped.

- When I turn it on I hear all the same/correct noises, no ticking or clicking
- Its not showing in device manager or disk management.
- I've taken it out of the housing and tried connecting direct inside the PC but that didn't make a difference
- I've tried 4 USB cables, not fixed it
- I've plugged a drive from an old PC into the housing to check if the issue was there and the old drive was picked up fine.
- I've plugged it into a laptop running windows 7, another running XP and a WDTV Live box, but no joy there either.

The product code is 31759000 RDHD-U

I'm at a loss as to where to go with it now, the drive IS my backup drive with a lot of sensitive / business related data on it. I figured that due to it sounding the way it should that the issue is not a mechanical one but if it wont be recognised by windows then what else is there?

Its worth noting that when I plugged it into the PC direct, upon boot up it was picking up the main drive and then on the second drive it jut said "SATA 6 ..." (whereas the main drive said SATA1 ... <drive name>) then hung for about 60 seconds before carrying on its journey. The windows loading/splash screen also took a long time to load when it was plugged in.

Is there any software that can aid the recovery of the data or is my only choice to send to data recovery people or bin it?

Many thanks
a c 119 G Storage
February 27, 2012 7:52:50 PM

http://www.cgsecurity.org/wiki/TestDisk

You can try this free software but am not sure that it will work if the drive is not even showing up , your only other option may be to send it on to the data recovery people. With all of the testing you have done it sure sounds like you have a failed drive.
m
0
l
February 28, 2012 5:43:52 AM

Just in case anyone else comes across this message, i'm pretty sure that the problem relates to the BSY issue detailed here: http://www.mapleleafmountain.com/seagatebrick.html.

It affects the exact model and firmware version I have and the symptoms are identical. As mine is out of warranty and at best all I could expect is a new drive rather than data recover (and I really need that data), I'm going to have a crack at this repair.
m
0
l
Related resources
a c 119 G Storage
February 28, 2012 4:01:00 PM

The link you posted is broken.
m
0
l
February 29, 2012 6:00:45 AM

Weird, works fine when I click it. Just Google the below and its the firs result:

mapleleafmountain seagatebrick
m
0
l
!