Sign in with
Sign up | Sign in
Your question

Answer me? These Questions 3 . . . please

Last response: in Storage
Share
February 27, 2012 10:55:04 AM

Mysterious Simultaneous WD Bad Sector Failures.
Can you help with the recovery?

My MagicBox workstation specs =
http://xyzcoord.webs.com/workstation.htm

OCZ 700 Watt Power Supply
APC Back-UPS ES 750 Watt
Intel Core 2 Duo E8400 - Overclocked 3.3 GHz
EVGA nForce 750i FTW Motherboard
EVGA GeForce GTX470 Video Card
Acer 24” LCD Monitor
8 GB 1033 MHz Kingston Hyper-X RAM
HighPoint RocketRAID 640 4 port SATA III card
120 GB Patriot Pyro Solid State Drive
500 GB Seagate Barracuda Hard Drive
2x 1 TB Western Digital Green RAID Hard Drives
3x BACKUP DRIVES

DVD-CD-RW Drive
CD-ROM Drive
Floppy Drive
HP 6988 Photo Printer
Epson Perfection 2400 Scanner
Olympus Stylus 550WP 10 MegaPixel Camera
Happauge WinTV-1600 Card
Microsoft Wireless Keyboard 3000
Microsoft Wireless Mouse 5000
Wacom Bamboo Create Tablet
Logitech G5.1 Speakers
Windows 7 Professional 64 bit

In my final drive config I plan to have:


C: Ssd - Highpoint SATA3 port 1 (320MB/s- fastest access to windows and productivity software)
D: Barracuda port 2 (120MB/s- fast access to games and programs)
. . . dying raid was D, raid is now R, will be deleted soon
E: DVD ide port master
F: CD ide port
G: new WD20EARS 2TB Green 1.2TB partition-0>port 3 (active STORAGE, documents)
V: new See above^ 0.6TB partition-1>port 3 (VIDEO, old docs, music)

X: External port 4 (backup)

Question #1: I am going to partition a 2TB WD green STORAGE drive to replace the raid. One 1.2 TB partition will be for STORAGE and a 0.6TB partition will be VIDEO. I would think the 600gb VIDEOs should be on the slower inside spindle surface of the disk. The active STORAGE should be on the faster moving rim.
When I partition the drive, should STORAGE be first or VIDEO?
Is this like short-stroking?


||<D:\STORAGE===============================>|< E:\VIDEO=====>|| - Is this correct?

Question #2: I was running a weekly defrag overnight when I got a BSOD saying something about power.
Of course, I was only defragmenting the 2TB raid-zero and the 2TB external backup Hard Drives.
The SSD has never been defragged.
I just got the SSD and the HighPoint RocketRaid on Christmas 12/2011.
The RocketRaid upgraded my old mb to run the SSD at SATA3, but it is 150% faster than the Nvidia raid as well.

There was no power outage, the APC-UPS is solid and the battery is less than a year old. It was 3AM and the computer was beeping like a fire alarm, so I just turned it off and went to bed. In the morning my PC was v...e...r...y slow. After days of hair pulling I found that somehow two of my year old WD drives simultaneously erupted with over 1700 bad sectors. One WD drive was in raid and the other was external (but plugged into the RocketRaid). After the damage, I had the PC running CheckDisk /scan & repair {in DOS} on the raid for 5 days to no effect. When I discovered that the raid had 500 bad sectors and my external had 1200, I low level formatted the 2TB external. That took over a day and did not fix a thing. The surviving drive (1TB half raid) is 3 years old. Luckily WD is replacing the drives under warranty. No loss of data {YET!}, but my rate went from 150 MB/s down to 7 MB/s.

What could make 2 drives die at the same time in the same way like that?

Question #3: I have 2 remaining backup drives that are working out great. A few of the most recent folders had to be copied a few at at time from the slow raid and what should have taken 1 hour, took many hours at 4MB/s max. There is no way I am going to wait 3 days to backup this damaged raid. When the new drives arrive, here is my plan.

1. Add the 3rd WD10EADS to the HighPoint card temporarily, then add the new drive to the raid in HighPoint bios, rebuild the array.
2. Reboot and enter the raid manager bios again, delete the damaged drive from the array, rebuild.
3. Shutdown and remove the bad sector drive, Install new WD20EARS 2TB, switch on, boot.
4. Format WD20EARS and Partition STORAGE and VIDEO.
5. Copy raid to STORAGE and VIDEO.
6. Delete the raid array in the HighPoint web manager.
7. Format the 2x 1TB (half raids) for use as a backup in eSATA dock.
. That makes 3 backup drives. A 1TB for video, 1TB for apps and 500GB for documents.
8. Remove 2x 1TB eSATA drives. Secure all drives and cleanly route cables.
9. Test.
10. Never screw the lid on before you are done, because that guarantees that you messed something up and are going to have to unscrew it again.

Will the HighPoint/Marvell-88SE9128 accept the new indentical drive and rebuild the raid to full speed?
Does this plan seem sound?

More about : answer questions

March 3, 2012 2:22:19 PM

HighPoint replied to say that consumer grade drives (and WD green drives specifically) are not compatible with professional RAID controllers.

Re: #3 - I screwed up the RAID so I just formatted everything.
m
0
l
Related resources
!