Usb device not recognized but only for my wireless card..everything else works

hello i 've seen this post about usb not recognized but this 1 is different.I use my computer for almost 2 years but nothing went wrong all that time except now that it doeshnt recognize my wireless card(belkin) and another weird problem i cant format my pc cuz when i boot it it pasts the boot screen like there is nothing inside it!i am using windows xp home sp3... i have tried many different ways like
1:update drivers
2:unistall drivers from device manager restart the pc and let it update them automatically...which i dont know why but it cant find any driver without internet help section
3:turn of computer and unplug it from the wall outlet
4:format it again to windows xp cuz its the only os it can actually read.
I am also using windows xp 32 bit and tried to format it to vista/7 32 bits...i hope i dont sound stupid cuz i dont know very good english but these are actually my problems..hope u can help me plzz cuz i cant afford to buy a new 1.
6 answers Last reply
More about device recognized wireless card everything works
  1. If your USB recognizes all other devices except your USB wireless card then most likely the wifi card is broken
  2. u mean ethernet card inside my pc or the wireless card cuz i pluged it into a friends laptop and it works with full drivers...forgot to mention all this happened when my little bro switched off the computer from behind at the on/off switch...
  3. If you do not have Internet when you are trying to update drivers then you will have to load them manually, windows XP does not have as many generic drivers as windows 7 has.
  4. well to tell u the truth i spent many hours in finding drivers manually like i my motherboard model drivers which i donwloaded all of them....i think the inside ethernet card is probably damaged + i cant format to windows 7 cuz its like there is not cd inside when i try to boot ....
  5. Your inside card can be disabled in BIOS.
  6. sorry but i forgot to mention i already checked my bios settings and there was nothing wrons as they were all options enabled.Still cant find the solution and i really have to get it fixed immediatelly.thnx for replying
Ask a new question

Read More

Wireless USB Storage