Sign in with
Sign up | Sign in
Your question

P55A-UD4 Raid setup

Last response: in Motherboards
Share
October 3, 2010 8:57:40 PM

Having just built my new PC with the P55A-UD4 I'm now experimenting with RAID.

What I want to do is to have a standalone SATA2 drive hosting with operating system and applications, and separately 2 SATA2 drives in RAID 0 for video editing. I understand that I want to be using the onboard Intel controller, but how do I go about configuring the standalone drive in conjunction with the RAID 0 combination?

Also, does it make a difference which of the 6 available SATA2 ports I use?

More about : p55a ud4 raid setup

a c 715 V Motherboard
October 3, 2010 9:24:14 PM

Welcome Newcomer! :) 

No, it makes no difference which port you use, but I always use the first (2) in this instance {SATA2_0, SATA2_1}. Once you setup PCH SATA Control Mode [RAID(XHD)], then Ctrl-I to pair the HDDs; use 128 KB stripe. Also, I assume these HDDs are exact matching drives?! Note: WD decided not to use TLER in their consumer lines which aides in overall RAID stability.

Further, I assume that you understand basic differences in RAID; in RAID 0 striping one HDD gets the 1's the other 0's if one HDD fails then you've got nothing {1/2 Data = 0 Data}.
October 3, 2010 10:07:29 PM

hi, thanks for your response.

I appreciate the risks in data loss associated with RAID 0, but I want to use this for performance reasons in video editing, and I'll be backing up the results in a separate offline storage.

What I'm not certain about is configuring a RAID in conjunction with a standalone drive on the same RAID controller. In your response, I'm not sure if that answered my initial query.

thanks
Related resources
a c 715 V Motherboard
October 3, 2010 10:36:06 PM

Yes, the other HDDs will appear as non-RAID members. Even though I did not see it referenced in your manual the other HDDs typically run in AHCI mode.

If this is a fresh install you'll need to look for F6 "pre-install" drivers for SATA/RAID. If you don't have a floppy then "I" use nLite to created a custom OS install disk. {don't forget to extract drivers}

Footnote: If any of the other drives have an OS and the RAID 0 is going to be the {primary} boot drives then disconnect the other HDDs prior to installing a new OS.
October 3, 2010 10:50:01 PM

jaquith, thanks for the clarification about non-RAID members. This is exactly what I was asking about but couldn't find anything anywhere explicitly stating this. This will be a fresh install and I did read in the manual about needing drivers for SATA/RAID.

I guess I'll just give it a go and see what happens.

thanks again.
a c 715 V Motherboard
October 3, 2010 11:03:19 PM

I'm posting on a SSD {OS + Apps}/SATA_0 & RAID 1 {Data}/SATA_2+_3 configuration as we speak. The SSD is a non-member; RAID is on-board with Intel ICH10R.

Good Luck!
October 3, 2010 11:22:20 PM

Out of interest, did you consider connecting the SSD drive to the Marvell controller for SATA3 operation?
a c 715 V Motherboard
October 3, 2010 11:56:23 PM

It depends on the SSD, if it were a Crucial C300 series then yes the SATA3. However, if the SSD has a SATA2 controller or SATA3 and is less than the SATA2 per device limit of 300 MB/s then I prefer the Intel SATA2 controller. Marvell controller is still problematic.

Keep in mind unless your HDD/HHD/SSD can break either the Read/Writes, regardless of the controller, for now you're better off on SATA2. I get 2-3 times a week people buying SATA3 HDD that are at best 2/3rds the way up the SATA2 speed and having to explain the {6Gb/s} has zip to do with their Read/Write speeds; it's just the controller type.
October 4, 2010 9:20:33 AM

That's a good point about the controller being the weakest link. I shall hold off on any SATA3 devices for now.
a c 715 V Motherboard
October 4, 2010 2:24:26 PM

When you get a chance I'd be interested how your RAID turned-out. My assumption is all went well!
October 4, 2010 3:54:01 PM

Yes, I will definitely update here, hopefully later this week. Thanks for your advice.
October 6, 2010 1:10:41 AM

jaquith said:
When you get a chance I'd be interested how your RAID turned-out. My assumption is all went well!


So I finally took the plunge and delved into the BIOS RAID on my P55A-UD4 and I couldn't believe how smoothly it went.

The configuration I was aiming for was a single SATA2 HDD for OS+Apps, plus 2x SATA2 HDDs in RAID 0 for data. I connected the HDDs to the chipset Intel controller, the standalone HDD in port4 and the 2 RAID member HDDs (500GB each) in port0 and port1 (I also have an optical drive in port5). Like you say, it doesn't really matter which ports are used, but for organisational purposes I chose to keep the RAID members in adjacent ports.

In the BIOS Integrated Peripherals, I set the PCH SATA Control Mode to RAID(XHD), then save and exit the BIOS. After the BIOS POST, I accessed the RAID BIOS setup utility to configure a RAID array. This was done by following the onscreen instruction to press CTRL-I to enter Configuration Utility.

The main menu for the RAID configuration utility has the option to Create RAID Volume, and my three HDDs were listed in ports 0, 1 and 4, initially with status "Non-RAID Disk".

In the Create Volume menu, I selected the RAID level 0 (stripe) and selected just the two HDDs in ports 0 and 1 to be RAID members, leaving the default strip size 128MB and using up the full capacity of the drives (just under 1TB). Back in the main menu, the two HDDs in ports 0 and 1 then showed as "Member Disk", whilst the standalone HDD remained as "Non-RAID Disk".

On exiting the RAID configuration utility, I had Win7 Pro ready to install from the DVD drive. During Win7 installation, both the standalone HDD and the new RAID drive was presented as candidates for the target installation. I chose the standalone HDD and this did not require any additional RAID/AHCI drivers.

After Win7 had installed, the RAID drive was not visible in Windows Explorer, nor was it visible in the Storage Disk Management snap-in of the Computer Management Console. Only after installing the Gigabyte motherboard Intel SATA RAID driver was the RAID drive available under Win7.

And that was it! Thanks jaquith for giving me the confidence to go forth and RAID.

Next I might have a play with the XHD feature :p 
a c 715 V Motherboard
October 6, 2010 1:57:25 AM

Very Cool! :sol:  Glad to have helped. Thanks for updating!

BTW - keep the RAID on Intel.
!