Sign in with
Sign up | Sign in
Your question

New Build Fails Memtest86

Last response: in Memory
Share
October 4, 2010 4:12:22 AM

Hi all,

Just finished my first build:

CPU: i7 930 (stock cooler)
MB: Gigabyte GA-X58A-UD3R
GPU: Whatever was lying in my desk drawer…
RAM: 6GB kit DDR3-1333
PSU: OCZ 700Watt ModXstream Pro

Once BIOS Posted and I passed out for a bit from all night build then going straight to work, I decided to run a few diagnostics before actually installing an OS (will be 64-bit Ubuntu btw). Turns out that Memtest 86 shows an error in the RAM (blithely slapping the self-satisfied smile off my face). The RAM consistently fails test 7 at address 2100dc98 over several passes. I ran WinDIag to confirm and found failure at the same address (test WINVC, if that actually means something to anyone). I ran several passes with the same address failing 5/8 times (the 8 passes actually produced 6 failures but pass 3 produced 2 errors on the same address).

I took a look at the BIOS memory settings and found that the CAS timings are set to 8-8-8-19, NOT the 9-9-9-20 timings given as the default by the manufacturer (see above link). The BIOS also has the 1333 memory running at 1066 MHz, which seemed odd to me. I'm not an overclocker (though I may soon change that) and this is my first build so I'm a bit out of my depth here, but I was wondering if it's possible that the CAS timings are causing the error.

It would be great if I could just change a few things in BIOS and make everything better. I doubt that's the case but I thought I'd ask before I started taking out modules and testing one at a time and, following that, making the trek back to Microcenter for the exchange.

Thoughts?

--Adrastus

More about : build fails memtest86

October 4, 2010 4:28:13 AM

I'd like to add that the same failure always occurs: the sixth character in the hex string sent to the memory is always off by -2. For example: Expected: 02020202, yields Received: 02020002. This consistency leads me to believe that there is in fact a problem with the RAM and not something else--memory controller, CPU, etc.--that is causing the problem. But I don't really have any kind of experience or knowledge to back that up, just the observations I gave above.
a b } Memory
October 4, 2010 5:58:14 PM

Sounds like a simple rma to me.
OZC is gaining a very bad reputation lately when it comes to ram reliabilty.
I was advised to stay away from it by people i trust in the industry 9 months ago.
Related resources
October 4, 2010 8:22:35 PM

Its the same address that fails each time? That tells me its bad RAM. If other addresses were failing intermittently, it could be the timings or voltage or something. The same address failing each time means that part of the memory is bad. Like Davcon says, get an RMA and return those. If you bought the memory recently you might be able to return them to the retailer for a refund or replacement, otherwise you got to send them to OCZ and let them replace the memory.
October 5, 2010 5:36:35 AM

So with three modules, {A, B, C}, and motherboard slots, {1, 2, 3, 4, 5, 6} I just tested the following combinations:
A1; =>
B1; => All three tests gave no errors...
C1; =>

Then, tested {A1, B3} and {A1, C3}--the motherboard manual says slots 1 and 3 should be used when using two modules--and found errors with both

This time however, it was a different test (the WMATS+ test in the Win Diag diagnostic), and a different address, but it was the same error: the sixth character in the hex string was off by -2. And it was the same address for both of the above configurations. I also tried to install 32-bit XP just for the heck of it (been running Puppy Linux from flash drive so far since BadRAM lets it avoid bad RAM) and the install blue screened...so much for that.

It seems to me that this would imply that that one of the slots on channel 2 (slots 3 and 4) might be bad...which really sucks cause this was my first build and I'd rather not have to go and get a new motherboard and build it all over again. I plan on going to microcenter tomorrow and getting them to take a look at it and replace whatever is wrong with it if necessary since they sold it all to me (for equal or better prices than Newegg I might add).

It also happens that the Win Diag test doesn't appear to like the 4GB of RAM when I use two DIMMs so I'll try Memtest 86 again but I'm not optimistic. I'm pretty sure I didn't shock or bend the mobo when I put it in so I'm hoping that's not it but it doesn't look good.

If anyone has any thoughts on this, perhaps some experience with motherboard testing and/or memory controllers on the new i7s etc. I'd welcome any advice.

Thank you all for your responses,

--Adrastus
October 5, 2010 6:39:19 PM

Just out of curiosity, did you test B1,C3 or C1,B3 (remove A from the equation) to see if you got the same results?

I don't think a bad slot could affect only a single address of memory at a time. You have 64 address lines and 64 data lines, and billions of bytes of data. If one of the lines were bad, you would have millions of errors.

Also, because you are using a Core i7 processor, there is no on-board memory controller, it's built into the CPU. So your options are now bad motherboard slot, bad CPU, or bad memory (and my money is still on the memory).
October 12, 2010 4:10:30 AM

Tuns out that it was a combination of two things: one of the memory DIMMs was bad AND my XP install disk didn't have SATA drivers which caused the blue screen I mentioned.

Simple trip back to Microcenter fixed both. Works great now and runs like a dream. Thanks everyone!
a c 347 } Memory
October 12, 2010 4:33:48 AM

Hopefully, didn't see any Gold's listed you are using DDR3 from this {Tested list} - http://memoryselector.cnetchannel.com/ocztech/result.as...

Install the RAM only in 1,3, & 5. The can be installed ONLY as follows; anything else is incorrect. Also do NOT enable XMP!!! BIOS: Load Optimized to test {I have this PITA MOBO:


Good Luck!
!