Sign in with
Sign up | Sign in
Your question

Amaze ATI HD 5770 Driver Problem

Last response: in Graphics & Displays
Share
Anonymous
February 11, 2010 6:27:54 AM

Today i brought a custom built pc which came installed with Windows XP. It worked perfectly and i did not come across any problems.

This being a computer with DX11 hardware i decided to install Windows 7 Ultimate, Which it did without a problem and i was able to install all drivers ... Except for the GPU.

When i install it and do the nesscecary reboot, i come to find that Catalyst Control Center cannot detect my GPU saying that it isnt there or it isnt working properly.

I then go to the device manager to find the GPU listed with a yellow exclamation mark. I then go to properties to find this message "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)" Anyone got any suggestions as to fix this problem?. A google search has turned up nothing.

My Specs are
CPU: Intel Core i5 750 @ 2.66 GHz
MB : Asus P7H55-M Pro
RAM: Kingston 2*2GB DDR3 1333 MHz
GPU: Amaze Raedon HD 5770
PSU: 450W Aywun
OS : Windows 7 Ultimate 32-Bit

I am a first time ATI user, and this ordeal has left a bad taste in my mouth.

February 11, 2010 6:47:24 AM

I have a similar issue with a brand new HD 5770. Windows 7 HP x64 detects my GPU and loads drivers for it, as does Catalyst, but most games will not detect it. Even if a game does detect it, it gets minor graphical errors in the form of random horizontal lines flashing from the right side of the screen. I've reloaded drivers twice now with no luck. I'll be boxing this up and swapping it for a GTX 285 or 295 tomorrow morning. At least half of the cards I get from ATI do this to me.
February 11, 2010 3:27:37 PM

go to www.amd.com and get your card's driver there... :) 
!