Sign in with
Sign up | Sign in
Your question
Closed

ATI Overdrive UNDERclocks 2D!

Last response: in Graphics & Displays
Share
February 12, 2010 5:36:10 AM

Anyone else here with a 5850 find that enabling ATI overdrive UNDERclocks their 2D GPU clocks?

With overdrive off my 2D clock is 400MHz (as verified from bottom of overdrive tab).
With overdrive on my 2D clock is 157MHz.

With overdrive on my screen flickers with black rectangles, and the desktop picture will momentarily shift horizontally and vertically. (And before you ask NO this is not a grey screen/lines issue)

I can verify that when I load up a 3D windowed game that the clocks pop back up to 765MHz and the flicker disappears.

For reference:
Catalyst ver 10.2 RC2
XFX ATI Radeon HD 5850 Black Edition (765 Core/1125 Mem stock OC)
Windows 7 x64 Professional
Gigabyte MA785GTUD3H
AMD Phenom II X3 720 (unlocked to X4 and OC'd to 3.2 GHz)
G-Skill Ripjaw CAS 7 1600MHz DDR (8-7-7 timings)

Also overclocking to 775MHz drops performance! (this is max that overdrive allows)
February 12, 2010 8:27:09 AM

775mhz is probably too much (@ nearly 200% increase....lol...). This is a feature of ATI's that is basically a power-saving mode. I have no idea why it underclocks that much though. Any option to set minimum clocks?
February 12, 2010 12:19:02 PM

No reason for the gpu top run at full speed when only using 2D. My 4890 drops the gpu speed down to 240MHz from an oc'd 910MHz when I only use 2D.

Also there was a recent THG article benchmarking 2D performance in the 5800 series of cards, you might want to give it a read as it may explain the flickering issue you mentioned.
Related resources
February 12, 2010 10:16:41 PM

When i first installed my 5850 the default settings were 157/300 (or something silly like that) and 850/1200 (dont ask me why bu thats my 5850's default clock). after installing the newest drivers and afterburner, It ranges from 400and850/1200.
February 13, 2010 1:22:48 AM

Yeah mine defaults to 400MHz, but overdrive reverts it back to that 157... seems like they fixed it in one place but forgot about it in overdrive...
February 13, 2010 5:14:57 AM

How come my 4870 only underclocks to 600/450?
February 17, 2010 3:34:13 PM

I just finished a new build and installed a 5870 and have the exact same problem. I am using stock speeds and my clocks are 400/1200 when the system is idle with average temps of 53 deg C. I actually want the system to downclock to 157/300 with 2D apps to bring down the average temp. But the only way I can achieve this is through Overdrive but my screen flickers with Overdrive enabled. I have opened a ticket with XFX just a few minutes ago.
February 17, 2010 4:35:02 PM

its because you have dual monitors (or more). I am using dual monitors and my 2d low power clocks are 400/900. if you are using single monitor they are 157/300.

However 157/300 is obviously not enough for dual monitor so ATI made it 400/900. However there is a bug on drivers and Overdrive when you overclock your card (or underclock or only enable overdrive in some occasions) it drops the default to 157/300 which starts causing screen flicker.

Its annoying and I am not sure if it can be fixed from drivers or its bios issue. if you want to overclock your card you have few options:

1. Use overdrive only before starting game and turn off your second monitor to not irritate you
2. Use some other apps for overclocking
February 17, 2010 5:04:56 PM

Rawsteel, Great input. Absolutely makes sense. Thanks for saving me a ton of research and re-loading drivers.

Best solution

March 1, 2010 4:43:13 AM
Share

the 2d clock seems to be the problem you can access the the clock rates though the profile manger in options though the save config file that appers when you save a profile locataion C:\Users\{yourusername}\AppData\Local\ATI\ACE\Profiles

and instructions can be found on post 10 of this thread on the amd forums

http://forums.amd.com/game/messageview.cfm?catid=260&th...

i have apply-ed the setting like instructed it didn't help but then i played with the voltage setting i set it to
<Feature name="CoreVoltageTarget_0">
<Property name="Want_0" value="1000"/>
<Property name="Want_1" value="1000"/>
<Property name="Want_2" value="1125"/>

which is 1 volt
that seem to help i also set the core clock and the memeroy to

<Feature name="CoreClockTarget_0">
<Property name="Want_0" value="39800" />
<Property name="Want_1" value="60000" />
<Property name="Want_2" value="86000" />
</Feature>
<Feature name="MemoryClockTarget_0">
<Property name="Want_0" value="120000" />
<Property name="Want_1" value="120000" />
<Property name="Want_2" value="120000" />

this has greatly reduced the occurrence or at least has changed the time at which they appear i think with further tweaking i may be able to eliminate the distortions but it will take time and i am very busy if any one else wants to take a crack at be my guest just read the instruction on the amd forum and don't do anything stupid like assigning too much voltage i will post the fix settings if i have time to mess with it more another thing i might look into not sure but using gpuz to monitor my clock i noticed that it switches to 3d mode quit often and that the distortion dont seem to be directly happening when the switch occurs but i have a hunch it may also have a role in the problem
March 1, 2010 4:59:09 PM

Best answer selected by ljbade.
September 24, 2011 9:03:09 PM

wolfwood72 said:
the 2d clock seems to be the problem you can access the the clock rates though the profile manger in options though the save config file that appers when you save a profile locataion C:\Users\{yourusername}\AppData\Local\ATI\ACE\Profiles

and instructions can be found on post 10 of this thread on the amd forums

http://forums.amd.com/game/messageview.cfm?catid=260&th...

i have apply-ed the setting like instructed it didn't help but then i played with the voltage setting i set it to
<Feature name="CoreVoltageTarget_0">
<Property name="Want_0" value="1000"/>
<Property name="Want_1" value="1000"/>
<Property name="Want_2" value="1125"/>

which is 1 volt
that seem to help i also set the core clock and the memeroy to

<Feature name="CoreClockTarget_0">
<Property name="Want_0" value="39800" />
<Property name="Want_1" value="60000" />
<Property name="Want_2" value="86000" />
</Feature>
<Feature name="MemoryClockTarget_0">
<Property name="Want_0" value="120000" />
<Property name="Want_1" value="120000" />
<Property name="Want_2" value="120000" />

this has greatly reduced the occurrence or at least has changed the time at which they appear i think with further tweaking i may be able to eliminate the distortions but it will take time and i am very busy if any one else wants to take a crack at be my guest just read the instruction on the amd forum and don't do anything stupid like assigning too much voltage i will post the fix settings if i have time to mess with it more another thing i might look into not sure but using gpuz to monitor my clock i noticed that it switches to 3d mode quit often and that the distortion dont seem to be directly happening when the switch occurs but i have a hunch it may also have a role in the problem



I tried this method with my 5970... everytime i save the file it with the new values it get overwritten back to the old values
October 30, 2011 5:24:29 PM

Thanks Woolfwood, I've been looking for a solution for this for a long time, putting the clock up by a 100mhz can add quite a lot to my FPS (Starcraft 2 goes from 60 to 100+, not exactly needed, battlefield 3 goes from 30 to 60, wonderful) but it was a pain in the ass when it made the desktop a pain to use!

ASh83 said:
I tried this method with my 5970... everytime i save the file it with the new values it get overwritten back to the old values

Make sure you close Catalyst Control Center before you save the changes or it will just reset.
!