Solved

Gigabyte X58A-UD3R not recognizing eSATA drives

So I have this new computer from CyberpowerPC, built on a X58A-UD3R mobo. Everything seems to be working OK (still have to get some benchmarks done to see how it runs, something to assess gaming performance really).

My main issue right now is that my Fantom Drives external eSATA won't show up at all in Windows. I've got two of the 1TB drives, and a 2TB drive, all are dual USB/eSATA enclosures.

1) Both drives are recognized via the eSATA port on my laptop.
2) Both drives work on the CyberpowerPC via USB connection.

Neither Cyberpower nor Gigabyte have been able to tell me what the problem here is. Any suggestions?
Reply to sentry1
18 answers Last reply Best Answer
More about gigabyte x58a ud3r recognizing esata drives
  1. Are all the controllers turned on in bios?
    Check that the front panel is wired to mobo.
    Reply to mhelm1
  2. Welcome Newcomer! :)

    Q - What drives, besides the {external} are connected to the MOBO?

    Next, my first guess is that CyberPowerPC did NOT set-up the eSATA as AHCI in the BIOS, and "IF" you plugged-in an external HDD "HOT" meaning you system was on a corruption is more likely the culprit. To attempt a repair enter the BIOS and change the eSATA {IDE} to {AHCI} and reboot with the drives disconnected.
    Reply to jaquith
  3. Internally I have a DVDRW drive and HD plugged into the onboard SATA ports.

    I am using the eSATA ports on the mobo back panel, and I've verified the eSATA controlled is enabled and running in AHCI mode. Still nothing.

    These are, btw, combined eSATA/USB2.0 ports. Ingenious design in my opinion, squeezing 2 eSATA and 2 SATA ports in with the 4 USB ports. (Sidebar, why have SATA ports available externally?)

    Anyway, no luck with the eSATA ports. Plugging the drive in via USB cable into the same port has it showing up in Vista just fine though.
    Reply to sentry1
  4. ^ Again, did you plug-in the eSATA "HOT" prior to the BIOS change?
    Reply to jaquith
  5. jaquith said:
    ^ Again, did you plug-in the eSATA "HOT" prior to the BIOS change?


    Oh, yes, I did hot plug the drive prior to the change. This time around I unplugged the drive, rebooted, checked the BIOS settings, then went into Windows and plugged in the drive.
    Reply to sentry1
  6. Okay, lets try simple first to correct any corruption:
    1. Shutdown & unplug eSATA HDD, Run System Restore and "hopefully" find a restore point prior to the "hot swap" time-frame then shutdown and reattach eSATA HDD.
    Failure
    2. Shutdown & unplug eSATA HDD, goto eSATA HDD site to see if any compliment {OS environment} drivers are available and install, shutdown and reattach eSATA HDD.
    3. Shutdown & unplug eSATA HDD, D/L and reinstall all SATA drivers from GA then shutdown and reattach eSATA HDD.
    GA (rev 2) - http://www.gigabyte.us/products/product-page.aspx?pid=3449#dl
    Failure
    4. Shutdown & Plug-In eSATA HDD, open Device Manager and if present & non-functional right-click listed eSATA HDD and click delete, and restart.

    FAILURE:
    Verify that the eSATA HDD can indeed run-off a powered eSATA port a/k/a eSATAp.
    Reply to jaquith
  7. Also, you may need to Enable in Windows 7 after OS install:
    Excellent tutorial: http://www.sevenforums.com/tutorials/61869-ahci-enable-windows-7-vista.html
    Reply to jaquith
  8. Nothing worked. As a last, desperate resort, I wiped my internal drive, made sure all the SATA and eSATA controllers in the BIOS were set to AHCI mode, then reinstalled Windows Vista.

    The backpanel eSATA ports are running in AHCI mode (not IDE or RAID)

    I loaded all the SATA drivers from the Gigabyte site, and I know the internal drive is working in AHCI mode.

    The Intel ICH10R SATA AHCI controller shows up in the device manager, as well as a Standard AHCI 1.0 Serial ATA Controller.

    Unfortunately, still nothing when I plug in the eSATA drive. Not even a blip out Windows. I have the feeling some small but important detail is being skipped over here, somewhere... I just don't know what it is.
    Reply to sentry1
  9. Well I wasn't going to go that far to reinstall the OS; I was going for a possible corruption.

    Goto the eSATA OEM site and see if they have a driver for their drive. Also, please post the info about that drive {name or link}. Does eSATA drive appear in the BIOS?

    I did note {Fantom Drives} and I do see both drivers and firmware listed - http://www.micronet.com/support/software.htm
    Reply to jaquith
  10. It is a Fantom GreenDrive 1TB, model GD1000EU. And it doesn't show up in the BIOS.

    None of the drivers on the Fantom Drives website are applicable, they are only legacy drivers for XP or NAS drivers as far as I can tell.
    Reply to sentry1
  11. Start a ticket with GA - http://www.gigabyte.com/support-downloads/technical-support.aspx

    MOBO issue seems logical.

    Options: 1. SATA to eSATA plate, 2. USB 2.0, 3. Pixie Dust.

    BTW - I had to RMA 9/10 of my UD3R and still cannot run SSD + RAID {H/W design issue}.

    Reply to jaquith
  12. I gave up, I had issues with the memory being stable at it's base speed of 1600MHz (turns out it was just rebranded 1200MHz chips), and other problems, so I just returned the system and paid out some extra dough for a better one built on an Asus Rampage III Extreme board.
    Reply to sentry1
  13. Best answer
    Not too surprised the I think the GA-X58A-UD3R sucks!

    Good Luck on your ASUS!
    Reply to jaquith
  14. Best answer selected by sentry1.
    Reply to sentry1
  15. Install this driver, unplug esata and reset you computer, this solved it for me. surprisingly this is not included with the ud3r driver cd.

    ftp://driver.jmicron.com.tw/SATA_Controller/Windows/JMB36X_WinDrv_R1.17.59_WHQL_eSATA.zip
    Reply to alaskanrabb
  16. Thank you sooooo much! Have x58A-UD5 ver. 2 and was having same issue. My best 'not so elegant' solution was HotSwap! but t didn't recognise drive on connect - required harware scan (extra mouse clicks and step's). Did a system image first and then tried this driver - yeah! works perfectly now!
    Reply to technicalfun
  17. alaskanrabb said:
    Install this driver, unplug esata and reset you computer, this solved it for me. surprisingly this is not included with the ud3r driver cd.

    ftp://driver.jmicron.com.tw/SATA_Controller/Windows/JMB36X_WinDrv_R1.17.59_WHQL_eSATA.zip


    Tried this soultion and it also worked for me on my MSI X58 motherboard on which my eSata port was not being recognized by my external Fantom drive. Thanks.
    Reply to alalamo
  18. Had a similar problem with the Gigabyte X58A-UD3R Rev1.0 board.
    Even when first installed, the eSATA socket did not always work with my attached SATA drive dock. Originally I found that just swapping the connection to the other eSATA connector solved the issue on WinXP 64 and then on Win 7 64 Pro. But on upgrading to Win10 recently both connectors failed to recognise the dock and no drives appeared in the storage lists.

    Having examined this forum thread, I tried the link from above messages <ftp://driver.jmicron.com.tw/SATA_Controller/Windows/JMB...>, and installed the downloaded driver. Re-booted and immediately the dock pops up and opens a content window for the SATA drive.

    Excellent result. Many thanks for exactly the right posting and link here.

    Why Gigabyte don't have this in their driver info, I really don't know. Now I can get on with fast backups and transfers again.
    Reply to peterjhb
Ask a new question Answer

Read More

Gigabyte Motherboards