Sign in with
Sign up | Sign in
Your question

USB Ports Transferring Extremely Slow

Last response: in Motherboards
Share
October 5, 2010 7:36:09 PM

System:

Windows 7 Professional 64
Gigabyte GA-770T-USB3 Motherboard
OCZ FATAL1TY 550W PSU
AMD Phenom II X4 955 Black Edition Quad 3.2GHZ
Kingston SSDNow V Series Gen II 64GB - Main
Western Digital Caviar 1TB 3.5" Internal Hard Drive - Secondary
8GB (4x2G) of Gskill RipJaw DDR3 Memory

So I've had this rig for roughly 2 months. In it's short life it's been in and out of tech shops, disassembled/reassembled more times than I'd like to count. RMA's have been done on both hard drives and the memory.

And finally, sweet merciful god, finally I think it's stable. (Turns out the faulty memory was the last missing piece to it all).

Now that I have a machine I can work with and install programs on/transfer my old backups off my external hard drives I have another issue. Much smaller, but extremely annoying none the less. Essentially, none of my 10 USB ports (front or back) will transfer files faster than 900kb/s. As I type I've been transferring a 350MB file onto a flash drive for just under 10 minutes now and it's almost done. I had to leave my pc run for over 2 hours to transfer the 7Gb StarCraft 2 installer, might as well have just re-downloaded it all over again.

I know it's none of the units themselves, I'm working with 2, 1TB Lacie USB 2.0 External drives and a Kingston 8GB Data Traveler. All of which I've used on my laptop to move large files around at regular speed. As soon as I plug it into the tower though I sit here forever. I'm running the latest drivers for the board, and not that it matters (I think) but I also have 2 USB 3.0 ports (of which I have no devices/cables capable of it) which I've tried and not tried using for these drives, not that it makes a difference. Every time I plug in/turn on a USB drive the Windows pop-up appears telling me I "this device can perform faster if I plug it into a Hi-Speed USB 2.0 port" but when I click on it to list the devices, it says I have no Hi-Speed USB 2.0 ports installed.

If it matters, my device manager currently lists for USB Controllers:

2 x NEC Electronics USB 3.0 Host Controller
5 x Standard Open HCB USB Host Controller
2 x USB Composite Device
2 x USB Mass Storage Device
5 x USB Root Hub

I've tried uninstall them and letting Windows rediscover them, didn't change anything. The odd thing is, as previously mentioned about having many technical issues, I've transfered many files to and from these drives before on this machine with no issues. I just don't know if somehow something recently changed, and why.

a c 716 V Motherboard
October 5, 2010 7:57:48 PM

Well first - You have a heck of lot more patience than I do.

It "seems" like a driver has become corrupted or needs updating. Begin with (1) and progress through (3) if needed; meaning if step (1) repairs the problem then stop, or the next step(s) until the problem is resolved.

1. Verify & Download the latest drivers {VERIFY OS TYPE e.g. Win 7 64-bit don't mix} for BOTH your MOBO and for your external HDD, Flash Drive, etc:
a. D/L - "if available"
b. Install/Reinstall them
c. If Flash drive/external drive(s) verify if any relevant firmware is available.
d. optional: reformat Flash.
e. Run Driver Agent and print results - http://www.driveragent.com/gigabytepromo.php

2. {Update USB via Windows} Open the Device Manager:
a. Open Device Manager
b. Next scroll down to [X] Universal Serial Bus controllers and click/expand [X]
c. Last right-click ALL listed items (1 by 1) and Update until all are updated.
d. Restart.

3. {Corrupted USB} Open the Device Manager:
a. Open Device Manager
b. Next scroll down to [X] Universal Serial Bus controllers and click/expand [X]
c. Last right-click ALL listed items (1 by 1) and Unistall until all are deleted.
d. Restart - ALL USB devices will be reinstalled and driver + corruption repaired.

Good Luck!
m
0
l
October 6, 2010 5:14:08 AM

Step 1, done, no change. Verified it was Windows 7 64 bit drivers. Driver agent said the following were out of date (none seem to be relevant from what I can tell though):

IDE ATA/ATAPI controllers
-Standard Dual Channel PCI IDE Controller

Sound, video and game controllers
-ATI HDMI Audio (Which by the way isn't even plugged into the motherboard, I'm using a different audio connection which is listed as up to date)

Also Lacie had no listed drivers on their site for my device. The closest was a "USB Boost" file but when I went to run it, it said it was incompatible with Windows Vista and above OS's.

Step 2, it said drivers were up to date for all USB devices. Though it also said the same thing for the devices that Driver Agent said weren't.


Step 3, had to use a PS/2 usb converter to be able to uninstall all, but I did, still no change. After I restarted Windows said there was an issue installing the driver and directed me to download the driver from Gigabyte. The interesting thing is the site downloads a driver that will then display as "Renesas Electronics USB 3.0 Host Controller" whereas if I install from the supplied CD-ROM it will display as "NEC Electronics USB 3.0 Host Controller". I did it both ways (uninstalling then reinstalling with one driver, then uninstalling all again and trying with the other) but neither fixed the issue. Also the only USB driver on the Gigabyte site for my board was this USB 3.0 one. Nothing regarding the standard 2.0 plugs I have.


EDIT: FIXED!

Ok this was a real stupid easy fix. Though I would like to say I remain blameless as I have not been touching the BIOS since I got my computer back from the tech shop. Apparently while it was there, someone saw fit to disable my USB 2.0 Controller option in the BIOS. No idea why. To be honest I was not even aware it was an option/possibility, but apparently it is and was disabled. A simple enable, restart and I'm back to transfering at high speeds. Appreciate the help regardless, mystery solved :D 
m
0
l
Related resources
November 29, 2010 9:46:50 PM

Please help me your the only person that ive seen REALLY USE usb 3.0.... im using a WD pastport 1tb with hitachi 360 hdd x2.... went and got a PCI E usb 3.0 card... updated what i could for drivers and it still seems REALLY REALLY slow 190GB in 2hours??? is that right because usb 2.0 seems to be getting the same do i need to go and disable the usb 2.0 in bios or am i confused and are problems were different?
m
0
l
November 29, 2010 9:48:08 PM

and its the 3.0 version of the mypassport 1TB since anyone else i ask seems to just fight the correct hardware use...
m
0
l
!